1

I followed the steps from Bukkit.org but it still resulted in the problem I'm having. I made a .bat file:

@echo off  
java -Xmx1024M -Xms1024M -jar craftbukkit.jar -o true  
pause

After I run the bat file it results into this:

CMD output Couple of things I've already looked at:

  • My craftbukkit.jar is named craftbukkit.jar and not craftbukkit.jar.jar (file extensions are ON)
  • The above .bat file I'm running is in the same folder as where the .jar file is placed
  • I have installed the latest version of Java
  • I run the .bat file as Administrator
  • The .jar file had some protection (because it was downloaded from the internet), but I removed that

Also, when I run the .jar directly with Java (double click and run it with Java) it works, generates worlds and other files. Sadly, I don't get a console or any other interface.

I'm trying to run this on Windows 10 Pro.

UPDATE

Moved the .bat somewhere else in response to Adam's response and found that the error was given anywhere. Specified the code:

@echo off  
java -Xmx1024M -Xms1024M -jar "H:\Program Files\Minecraft\Bukkit server 1.8.8\craftbukkit.jar" -o true  
pause

Ran it again and it's loading libaries! I can tell it generated files but I can't find out where. It's not located in the same folder as the .jar and .bat files.

CMD output

Anyone know where they could be?

  • If it's under program files folder then it may be inheriting permissions from parent folder. I would re download if you can't find it, and put it somewhere that isn't controlled by OS. Also, I recommend using YAMS to run a server on windows. That allows it to keep running whether you are logged in or not or if others use your computer. It also manages your server nicely. Setup is a pain until you know how it works, but is super worth it if you plan to keep a server up and running all the time. – ydobonebi Aug 6 '15 at 16:48
  • @ydobonebi Thanks for this! I'm not planning on keeping it going all the time though, just as a place where me and my friends can play together. But it's something to keep in mind. I put the files on my desktop and ran it, but it didn't work. Showed 'loading libraries' but no files were generated in the folder. – MaxForce Aug 6 '15 at 17:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.