5

Everything was working perfectly until a week ago.

But one day, i started Steam, go to my Library. And saw all of my installed games are showing as not installed. Also when i try to to install them Steam says i don't have any disk space. But i do!!

My OS: Ubuntu 14.04.2

What i tried
Uninstalling, manually removing all the data in ~/.steam and ~/.local/share/steam and re-installing

Tried to contact Steam Support, but no response.

  • Well, just by description it's acting like the space where it stored games is gone. Have you had any changes to your drives lately? Anything else worth mentioning happen a week ago? I don't know enough about Steam on Linux to be too helpful, but that ought to get the ball rolling for me and others, and I'll poke around on Mint in the meantime. – Radhil Aug 9 '15 at 13:52
  • No harddrive is fine. I have one drive and everything is installed there. – Can Vural Aug 9 '15 at 13:53
  • If I'm reading this right, removing ~/.local/share/steam would have removed everything, nuclear option on steam and its games. So the question is no longer why aren't the games showing up, it's why won't they install? And it says no space? What does df say? – Radhil Aug 9 '15 at 14:23
  • Yes. I backed up the games. And placed it again after the reinstall. Still no luck. And df says i'm only using 22% of my drive. So there is plenty of space. – Can Vural Aug 9 '15 at 14:38
  • Well, I'm not much help then. But I did find this bug report. Looks recent. (updated link with better one) Says something about a kernel update in Ubuntu? – Radhil Aug 9 '15 at 14:44
2
+100

It looks like this was a bug related to Ubuntu's kernel 3.13.0-59, and was found documented and discussed on Steam's Github repo. The bug prevented Steam from accessing it's own library folders.

Ubuntu has since updated the kernel again to 3.13.0-61 and this update will resolve the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.