The quest tells me to escort Esbern, even though he is nowhere to be found, and when I select the quest it gives me a marker to Delphine.

I checked Esberns cell and no one is there. What could be going on?

I play on Xbox 360.

  • 1
    Did you get him from his cell after infiltrating the thalmor embassy? At what time did you lose track of him? – Svj0hn Aug 8 '15 at 15:24
  • As soon as I fast traveld poof he was gone – austin Adams Aug 8 '15 at 15:26
  • Do you have a save from before he disappeared? If so, try reloading. Also, you could try going to delphine and waiting (T on PC, not sure how you do it on console). – Svj0hn Aug 8 '15 at 15:28
  • Well I left the mission alone now I'm a level 25 XD and I can't progress in the story without this quest done – austin Adams Aug 8 '15 at 15:30

If I remember correctly, Esbern is slow in walking. Head over to Delphine and wait a day or two in-game to see what happens.

If Esbern is still missing, try to fast-travel somewhere else and then back to Riverwood. Sometimes, you can just go into a building and he'll automagically teleport to you.

He might also still be wandering around Riften or the roads between Riften and Riverwood.

If you are on PC and Esbern is still missing (he's annoying), force him along with the console:

prid 00019DFD
moveto player

If you are on console, you're going to have to revert to a known working save. With Skyrim, always remember to save early and often.

| improve this answer | |
  • CAn you use the console in Xbox 360? – Young Guilo Sep 14 '15 at 6:26
  • 3
    @YoungGuilo Sadly, no. The console is PC only. I'll see if I can find an Xbox compatible method to "cheat" him. – Kaz Wolfe Sep 14 '15 at 7:00

According to this link, you might have to find the location with the help of other NPC's:

After infiltrating the Thalmor Embassy, return to Riverwood and inform Delphine of what you learned from the Thalmor records. Delphine is surprised to know her old colleague and fellow Blade, Esbern, is reportedly still alive. She tasks you with finding the archivist from his hiding place in Riften. Due to the clandestine nature of the Blades, Delphine gives you a secret phrase to deliver to Esbern in order to secure his trust when you locate him. Depending on your standing with the Thieves Guild, the journal will direct you to talk to Brynjolf, or search the Ratway for Esbern. If you are directed to find Brynjolf, you may speak to him, Dirge, or Vekel the Man inside The Ragged Flagon. All three give an option to persuade or bribe them for information on Esbern's location.

Of course, they will reveal that Esbern is in the Ratway Warrens, where his hideout truly is. Of course, what happens after that... You can find out for yourself or meet the spoilers in the link I gave you.

| improve this answer | |

If you fast travel to Riverwood after getting Esbern from the cell, but Esbern is not with you nor at the Sleeping Giant Inn where Delphine is, Delphine will say something like, "What!? You left Esbern alone?" After that, fast travel back to Riften, then back once again to Riverwood. Esbern should then show up at the Sleeping Giant and you will enter while he is in mid-conversation with Delphine. It's definitely a glitch, but the above worked for me

| improve this answer | |

When this happened to me, he was slow walking around in the section of the map near his hideout. Once I went over there, he exited the door then teleported to Riverwood. It’s a little strange, but I was able to go on with the story.

| improve this answer | |

I found the solution.

Fast travel to Whiterun and enter your house. Deposit an item and then fast travel to the location where you should have been heading. In this case it would be Riverwood.

You'll walk in on the start of their conversation together.

| improve this answer | |
  • 3
    Any source for this? Why does "depositing" an item help? – Svj0hn Sep 14 '15 at 6:21
  • This also assumes the user has a house. Are you sure it was not just the fast travel that fixed it for you? – user106385 Sep 14 '15 at 6:27
  • @Svj0hn I was looking on Gamepedia and for some reason depositing an item resets the account like a tick. So when the account resets you'll find that the quest resets and you'll pick up where you left off. – Young Guilo Sep 14 '15 at 6:33
  • @YoungGuilo Also, what exactly do you mean by "deposit"? Just leave something in a chest? It seems unlikely to reset anything at all. – Svj0hn Sep 14 '15 at 12:58
  • @Svj0hn Fast Traveling did nothing for me. Esbern still was missing. On the Skyrim forums there was a post to deposit items in your home. I did it and then it worked. – Young Guilo Sep 16 '15 at 6:59

Fast travel to river wood and see Delphine,he will probably be there

| improve this answer | |

It sounds like it has glitched out, you may have to restart.

You usually find him in the jail cell within the guild and have to take him back to Riverwood (where they talk catch up). He has a book in his pocket and he gives you the quest for Alduin Wall..

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.