0

I need help with fixing Steam on my PC.

Whenever I try to use Steam via their website or the Steam platform or anything it does not load at all.

  • From my browser I either just get a blank page or "Secure Connection Failed"
  • On the platform I either also get a blank page or "Error -107"

I have tried:

  • Reinstalling Steam; Didn't work.
  • Running a complete PC scan; nothing there.
  • I contacted Steam's support from my other computer; no response for 4 weeks now.
  • Rebuilding my ClientRegistry.blob; didnt work.
  • Validating Game Cache; didnt work.
  • I asked on the steam support Reddit page; no answer.
  • I tried working out some other things and nothing helps.

I don't have a proxy, I have a stable internet connection with a modem and I'm not in Steam's Offline mode.

Anyone have any idea how to fix this?

  • 1
    Are you behind a proxy or anything ? How do you connect to the internet ? – Ealhad Aug 9 '15 at 12:37
  • 1
    This might be a silly question, but are you in Offline Mode? – MattR Aug 9 '15 at 13:13
  • I dont have proxies,I have a stable internet connection with a modem and I'm not in offline mode – DeZ Aug 9 '15 at 18:40
  • RE: The other PC you're using to contact Steam support - are you doing this on the same internet connection? – Robotnik Aug 10 '15 at 1:07
  • I was doing it from the same internet connection but with a different IP and I also tried with my own IP on my other PC and steam still works – DeZ Aug 10 '15 at 9:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.