4

I'm trying to follow the quickstart guide.

When I made a [first] room and marked it as a stockpile, dwarves didn't do anything.

When I did the same with a room closer to the starting wagon, dwarves began to haul items to it. When I removed stockpile from the second room they still don't move things to the first one.

There is only one dwarf which moves maple wheelbarrow back and forth, others just drink booze.

enter image description here

1
  • 2
    I'd guess there is something wrong with the settings of your stockpile!
    – aslum
    Commented Aug 11, 2015 at 15:54

2 Answers 2

5

Philipp's answer is a good general purpose answer for debugging stockpiles. In this case however, I believe that none of the options mentioned in it are the problem. My belief comes from the final paragraph in your question.

There is only one dwarf which moves maple wheelbarrow back and forth, others just drink booze.

If a stockpile has any wheelbarrows assigned to it dwarves will only ever use those wheelbarrows to fill it. This works best for things like ore which is produced at a fairly slow average rate and is very heavy.

If this is indeed the case then to get all the other dwarves to help you need to set the maximum number of wheelbarrows for the stockpile to zero. You can do this from the building information exposed by the (q) command. (hit q move the cursor over the stockpile and then hit w until the max wheelbarrows number is 0)

I would guess that the other stockpile worked because there was no wheelbarrow to assign to it.

5

Usually dwarfs should always place any items into the nearest accessible and elligible stockpile no matter how far away it is, when the item is:

  • on the floor or in a building (like a workshop or the wagon you start with)
  • not marked as Forbidden
  • not marked as Dump
  • not required for a task another dwarf is executing right now (for example, when a cook starts to "Prepare a lavish meal" in a kitchen, the nearest four stacks of food are marked and won't be touched by other dwarfs unless the task gets cancelled)

A possible reason why this doesn't happen might be that the stockpile settings do not have the correct good type(s) enabled. Note that the settings are granular and don't just allow you to define what item categories to accept (like Weapons), but also what specific items which fall into those categories (like Battle Axes), what materials (like Copper) and where it applies also what quality levels (like +fine+). Make sure that the settings of the stockpile allows all the classifications of the items you want to store in them.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .