5

Background info: I was building a station similar to how the iss was built. So I added module by module. I placed a control module, with a drone core, lots of RCS fuel and SAS modules. After that I added a module where crew can live, with a bunch of science experiments. And the last component I added before this happend were the solar panels themselves.

Because I wanted such big arrays, I didn't launch everything attached. I had two poles with the solar panels, and a base that had three docking ports. One medium, to attatch to the space station, and two small for the solar panels. All three units had drone cores, RCS Control and small solar panels so I could fly them to their destination.

Problem: After I managed to add the solar panels succesfully, everything worked just fine. All physics were fine, and power was coming in. but when I exited KSP and loaded the save the following day to add the next component, all those solar panels started to freak out. I managed to close KSP with task manager before it saved, so I can make a video about it, and here it is:

.

As you can see on the map the next module was very close to the station, and then I noticed the solar panels doing it, because when I was further away physics weren't applied to it.

Sorry this got a bit long. But does anyone know what is happening here and how should I handle this? (turning off or on SAS and RCS does not work).

  • 1
    You might want to report this as a bug. Make sure to attach your savegame file to it. That way the developers will have a very good way to reproducte the problem. – Philipp Aug 11 '15 at 13:42
  • 1
    I always had some problems with large structures wobbling abit... But not like this. Not like this. – Svj0hn Aug 11 '15 at 15:03
  • Eh, even without SAS this happens sometimes. I had a mothership with 16 miniprobes for Eve. The way they started wobbling when in orbit (still under a fairing so for the first few tries I had no clue what happened!) made the ship disassemble itself. The solution was old and tested Moar Struts. – SF. Sep 3 '15 at 11:19
  • I couldn't add more struts in space because it wasn't modded. Though I recently cheated and rebuilt it, with more struts. It seemed to work at first (just like the old station) but when I reloaded it, I got the same problem. – Hap Sep 3 '15 at 15:41
2

SAS is your problem. If you turn it off, the oscillations should die out eventually. Additionally, you should be able to stop the oscillations using the time acceleration trick. The reason that the oscillations are increasing to destructive levels is that the parameters that control the SAS module are tuned to the natural resonance frequency of the station such that corrections are causing a positive feedback on the motion. Unfortunately, there isn't a way in the stock game to tune the parameters for optimal performance (what is known in control system parlance as critically-damped).

There is hope though. If you're using the Kerbal Attachment System (KAS) and Kerbal Inventory System (KIS) mods (they're best installed as a pair, but KAS is the only one you really need), you can attach struts to stiffen the solar panel beam relative to the rest of the station. Additionally, you can also change the resonant frequency of your station by adding to it. In particular, structures extending from the problem axis (in this case, the roll axis) will have the most effect.

Also, I can't tell if this is the case or not, but you only want a single SAS module active at any time on a non-rigid structure, or at the very least, have all the SAS modules on a single subsection of the station. At the very least, this will reduce the torque that's applied to the station, reducing the possibility of having an undamped system.

  • Nope, already tried that. – Hap Aug 19 '15 at 6:35
  • Already tried what? Just turning off SAS? Have you tried turning it off immediately when you load the station and leaving it off? Have you tried time acceleration? Unless there's a bug in the game that your station somehow exploits (which is entirely possible, but also unlikely), the problem lies with SAS. There is no other reasonable explanation. – MBraedley Aug 19 '15 at 10:18
  • I did both. Time acceleration just freezes the effect. As soon as it's 1x again they just continue doing their thing. – Hap Aug 19 '15 at 14:17
  • I actually just rebuilt the station as it was with struts at a lot of places, placed a rocket under it, infinite fuel and put it in an orbit. And now it doesn't break... oh well. – Hap Aug 19 '15 at 14:20
0

I also have had this exact same problem, on a ship with two gigantor panels! I tried turning off SAS, and used accelerator, but had the same effect. As soon as I went back to 1x time, it resumed oscillations exactly where they were. I also tried retracting the panels quickly, and hitting accelerator to 'pause' the oscillations while the panels retract. Even fully retracted with SAS turned off, the oscillations resumed as soon as time went back to 1x and increased in magnitude until the panels blew up. The only mods I have are MechJeb2 and Kerbal Alarm Clock.

I did manage to finally fix it temporarily using the following steps:

I turned my max simulation step time down to the minimum 0.01 seconds in the general settings page to help smooth the solver out a bit. Then, once I got back into the game and jumped to the ship, I immediately begin to see oscillations. At that point, quickly turn off SAS and tell the panels to retract, and hit 2x time warp to stop oscillations. Even at the time warp they will fully retract. With time warp still on, I returned back to the space center. Next time I jumped back to the ship again, the oscillations had stopped.

This definitely seems like a bug, because with the SAS turned off the oscillations should be damped and nothing should be adding energy to them.

0

I have this same problem. I just spent a few minutes testing the mods I had installed after managing to get all the way into orbit before the bug bit me:

(the button pressed at the end deploys robostrut grapplers for structural support) https://www.reddit.com/r/KerbalSpaceProgram/comments/2q6jh0/exploding_solar_panels/ I went to the launchpad, saved, and reloaded. It was fine. Turned off gravity, saved, reloaded. Still fine. Extended solar panels and waited with nothing bad happening. I then saved and reloaded and it went bezerk.

So I conclude that you must load a save with solar panels on arms/rods extended to reproduce this bug.

I was suspicious of the newly-installed 1.1.3 update until seeing this question. And others all the way to 2014-12-23: https://www.reddit.com/r/KerbalSpaceProgram/comments/2q6jh0/exploding_solar_panels/

Another YouTube video of the bug:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.