1

As a miner in Elite: Dangerous, I'm becoming very discouraged with my chosen profession for one simple reason:

The Refinery module glitches out randomly, showing "Refinery server connection unavailable" repeatedly, as well as showing that a resource needs allocation, and I'm unable to vent any refinery bins or the hopper.

My question is two-fold:

  • What causes this glitch to happen? It seems like it occurs when an element's bin fills up, and the current fragment would result in that bin reaching 100%. That's just something I've noticed, I'm not even sure if its related.

  • What are workarounds for the issue that would allow me to continue mining without quitting and restarting?

You have to power down the refinery immediately to avoid the obnoxious noises and messages, and I'm looking for a way to restart it in working order, without logging out.

Entering Supercruise will empty the hopper, which ends the glitchy noises and messages, but trying to mine again will make it glitch out immediately. The only fix I've found is to Save and Exit, then jump back in. That of course ruins the wing connection, changes the instance, loses any active limpets, etc.

Any workarounds for the glitch, or strategies to avoid the glitch, would be much appreciated.

0

Still no idea of the cause specifically, but I have found that the following will allow me to continue mining without restarting the game....

  • After the glitch occurs, shut down power to refinery (glitchy noise and msg should have stopped)
  • Supercruise outside current location, even if it's only for a second (refinery hopper should be empty after you get in supercruise)
  • Turn refinery back on while in supercruise (glitchy noise and msg should not continue)
    • Empty a bin from your refinery, just for good measure. Not sure if this has an affect or not, but I do it every time.
  • Supercruise back into location / drop out of supercruise
  • Perform "Reboot and Repair" in System > Functions menu

After reboot of ship systems, refinery should be online without glitch, and will accept fragments again without triggering the glitch.

This has worked for me three times in a row, hopefully it works 100% for everyone else.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.