5

After upgrading to Windows 10, I no longer get any audio when playing Dark Souls.

The strange thing however, is that if I restart the game in windowed mode, audio works perfectly fine.

In full-screen, I tried alt-tabbing, checking the volume mixer, and nothing seems astray, apart from Dark Souls not outputting any audio.

I have tried all the usual troubleshooting steps (ensuring latest drivers, restarting, uninstalling the game and re-installing), but nada.

Prior to Windows 10, I had 8.1, and the game worked flawlessly.


PC specs are as follows:

Operating System: Windows 10 Home Single Language 64-bit (10.0, Build 10240) (10240.th1.150810-2333)  
Language: English (Regional Setting: English)  
      System Manufacturer: Hewlett-Packard  
             System Model: HP OMEN Notebook PC 15  
                     BIOS: F.23  
                Processor: Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz (8 CPUs), ~2.5GHz  
                   Memory: 16384MB RAM  
      Available OS Memory: 16310MB RAM  
                Page File: 5259MB used, 13482MB available  
              Windows Dir: C:\WINDOWS  
          DirectX Version: 12  
      DX Setup Parameters: Not found  
         User DPI Setting: Using System DPI  
       System DPI Setting: 144 DPI (150 percent)  
          DWM DPI Scaling: UnKnown  
                 Miracast: Available, with HDCP  
Microsoft Graphics Hybrid: Supported  
           DxDiag Version: 10.00.10240.16384 64bit Unicode  

-------------
Sound Devices

 Description: SONY TV (Intel(R) Display Audio)
 Default Sound Playback: Yes
 Default Voice Playback: Yes
            Hardware ID: HDAUDIO\FUNC_01&VEN_8086&DEV_2807&SUBSYS_80860101&REV_1000
        Manufacturer ID: 1
             Product ID: 100
                   Type: WDM
            Driver Name: IntcDAud.sys
         Driver Version: 6.16.0000.3154 (English)
      Driver Attributes: Final Retail
            WHQL Logo'd: Yes
          Date and Size: 4/5/2015 23:53:29, 454416 bytes
            Other Files: 
        Driver Provider: Intel(R) Corporation
         HW Accel Level: Basic
              Cap Flags: 0xF1F
    Min/Max Sample Rate: 100, 200000
Static/Strm HW Mix Bufs: 1, 0
 Static/Strm HW 3D Bufs: 0, 0
              HW Memory: 0
       Voice Management: No
 EAX(tm) 2.0 Listen/Src: No, No
   I3DL2(tm) Listen/Src: No, No
Sensaura(tm) ZoomFX(tm): No
  • Playing on steam or standalone? Well never mind, found your request on steam. Do you have sound on the intro for a few secs or nothing then? – Nitro.de Aug 26 '15 at 7:54
  • 1
    What about another audio output e.g. on headphones, same problem? And you should check this question and of course this one too – Nitro.de Aug 26 '15 at 8:08
  • Tried headphones, no dice. No sound at all when starting up the game (if in fullscreen). It's worth noting I have the same problem with DS2 as well. No other game on Steam has the same problem. – cudiaco Aug 26 '15 at 8:41
  • Try to start the game in either fullscreen or windowed and press alt+return this will swap fullscreen to windowed and the other way around.. best is to start in windowed and use the combination to switch back to fullscreen.. see if the sound stays this way – Nitro.de Aug 26 '15 at 8:42
  • I tried unplugging the HDMI cable from my laptop to the TV and using the laptops monitor only, it fullscreens with audio no problem. Looks like there might be something to do with HDMI audio. Perhaps there's something different in how Windows 10 handles that kind of stuff. – cudiaco Aug 26 '15 at 8:51
2

Since I found out that there's something funky going on with HDMI audio, I set the headphone jack to be the default audio output device and plugged that into the TV, which got the sound working again in full screen.

Thanks for everyone's help.

Edit:

Another problem I faced was using InputMapper for my DS4 Controller as well, it refused to start in exclusive mode.

I tried the suggested fix suggested here, which didn't seem to work. I then tried unplugging the HDMI cable, and attempting the suggested fix (using the laptop's screen only), after which the controller worked again. Not only that, DaS worked flawlessly with audio in full screen as well.

It definitely seems like there has been a change in how Windows 10 handles HDMI audio/video output during startup.

I do hope that Microsoft pushes a fix for this in the future.

  • Looks like the latest windows 10 build (10586) fixed all of these issues. – cudiaco Nov 17 '15 at 7:06
2

I had the same problem.

I went back to check the problem and found out that the reason it actually worked was because before using nahimic, I went to control panel, then under Sound I went to manage audio devices, in the playback tab I went to Speakers, then went to properties and then to the spatial sound tab and changed it to windows sonic for headphones.

You could try it and see if your Dark Souls Prepare to Die Edition/ Dark Souls Remastered gets its audio back.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.