5

I wanted to make a few changes to my sleeping quaters. I had a bed in an office for the bookkeeper which i thought was a mistake, also my mansonry dwarf just constructed a master quality door, so i figured i would remove the door to his bedroom and replace it with the new master quality one. Figured he'd appreciate looking at his own masterpiece every day more than anyone?

I figured i would need to remove both with q-x. So i did the door first. It seemed to work - some dwarf came for it and picked it up. I paused the game and marked the bed as well. I unpaused. The door-dwarf dropped the door on the next tile, and while i was sitting waiting for him to pick it up again and move it further i saw someone was comming for my 'office bed'. Instead he picked up the table in the office and left the bed.

Picture showing the mess-up

I don't know what to do now. I tried to d-b-c (claim) on the door but it didn't work. Also i can't seem to target the bed for removal any more.

1) Is this normal or did i run into a bug? How can i get back to normal? 2) Bonus question. I tried placing the master quality door in the hallway but it doesn't let me pick the quality door - how can i select that specific quality door?

UPDATE: I figured out how to select the quality item: Before selecting the type of door (pressing enter) you can press 'x' for expand - then you get the list of items...

  • 1
    This is only tangentially related (not part of the source of your problems, just random unsolicited advice), but I noticed that the wiki window you have open in the background is for a much older version of Dwarf Fortress. You will want to make sure that you are reading the information about the correct version of the game for those situations (unlike this one) where the versions differ. – Nick Aug 27 '15 at 17:53
  • @Nick thanks for pointing it out :) when i find a page though google, I try to always click on the latest version but sometimes i forget :) – HojouHuman Aug 28 '15 at 7:43
14

There's no problem here actually. While it's true that there is a door at that place, it isn't a build door, it is an item.

You can see it if you look with k, when a dwarf deconstructs a building they will drop the components where they're standing, then when there is space in a stockpile it will be moved to the stock pile.

Make a furniture stockpile with enough room in it and the door (and bed) will be picked up when a dwarf is done drinking and resting and not doing what you want.

Also, the reason d-b-c (claim) doesn't work is because the door was never forbidden, it was just dropped and no one bothered to pick it up yet. =p

  • That's obvious :) I just didn't know... There are so many things to learn in this game :) – HojouHuman Aug 27 '15 at 8:59
  • The graphics are weird but still this game has very deep concepts that good graphics games don't have. – Fennekin Aug 27 '15 at 12:14
1

As Kevin said, the door is not built. If you really want to move it from there anyway, you can mark it for dumping: d-b-d

  • This is actually what i did. That way i got to use my claim afterwards as well ;) – HojouHuman Aug 28 '15 at 7:44
-1

I had a lot of space in my stockpile (set for Furniture and Finished Goods) but my items were never moved. I found it was set with "Will taken from links only" instead of the classic "Will taken from anywhere". It may happen to change it by mistake.

Use q-a to fix it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.