2

There are metallic parts of equipment on characters that tend to glimmer a lot, especially when the characters slowly bob back and forth. At times characters can almost look like a 70s Disco Ball straight from Grease.

Here's a small example:

glimmering piece of equipment

And an animated version:

animated gif of the effect

Is there any graphics setting I can tweak to reduce this extreme amount of glimmering?


To be more complete, for me personally this occurs with this setup:

  • Hardware / driver
    • NVida GTX 560 Ti
    • NVidia driver 347.52 and after updating also with 355.82
  • Graphics Options
    • Fullscreen mode "Windowed Fullscreen"
    • Resolution 1920x1080 60Hz
    • Vertical sync "On"
  • Graphics Settings
    • Resolution Scale 100
    • Mesh Quality "High"
    • Tesselation Quality "Medium"
    • Texture Quality "Medium"
    • Ambient Occlusion "HBAO"
    • Effects Quality "High"
    • Post-Process Antialiasing "High"
    • Multisample Antialiasing "Off"
    • Shader Quality "High"
  • 2
    Looks like aliasing artifacts. You could try Nvidia's DSR, but that won't fix it completely. As for anti-aliasing: I'm guessing your only option would be FXAA, which certainly won't fix this at all. But if you're lucky, DAI supports AA options other than FXAA. The downside is that MSAA, SSAA, and DSR all require an insane amount of horsepower. In the worst case, you'll have to mod the game to remove all normal maps for metallic textures, which would remove the light-reflecting effects entirely (no guarantee, though). – Nolonar Aug 27 '15 at 21:08
  • Thank you for your comment. Makes sense that it's got something to do with AA. Made me realize too my question was lacking detail on my current situation (which I've added just now) - I'll try to up the AA settings to see if that helps. – Jeroen Aug 27 '15 at 21:26
  • As I commented on @Yorik's answer, turning up AA and texture related settings unfortunately didn't help at all. – Jeroen Aug 27 '15 at 21:36
0

Going to be self-answering. Until someone comes up with a better idea, I think there is nothing you can do about this (barring hardware upgrades, possibly), because:

  • Updating the driver to the latest version as of 2015-08-31 (i.e. 355.82) did not help;
  • Turning all settings to their maximum value did not change anything;
  • Turning all settings to their minimum value did not change anything;

Seems this game with your particular set up just looks glitchy in this regard.

-1

This can be addressed, to a point, by using or increasing the AA (Anti-aliasing) setting(s) (https://en.wikipedia.org/wiki/Spatial_anti-aliasing ). The problem is that as the object "moves" some of the glimmer is at or near the pixel width and so it drops out and appears to flicker on and off. Basic AA methods render at a larger size and then reduce for display.

Another options to see if you can adjust is anything to do with "specular highlights" ( https://en.wikipedia.org/wiki/Specular_highlight )

  • Thanks for your comment. I've tried your suggestion, turning up the relevant settings (Mesh Quality, Texture Quality, Ambient Occlusion, Post-Process AA, Multisample AA, and Shader Quality) to the highest possible setting. Did not help one bit though :(. – Jeroen Aug 27 '15 at 21:34
  • bear in mind there is still a minimum pixel size, and you have arbitrary depth (as you you move the viewport, portions of the texture get smaller), so you won't be able to eliminate every example of it in all cases. The art the developers used for the specular maps may also be lower resolution than the main texture. en.wikipedia.org/wiki/… – Yorik Aug 28 '15 at 14:14
  • No offense (and also: not a -1 from me) of course, but though this is all interesting theory for sure, changing AA settings in game didn't alleviate the problem one bit... – Jeroen Aug 28 '15 at 16:53
  • I don't doubt that at all, I am just saying that there are lots of reasons why this may not be fixable 100% across the board, since it is a function of sampling and size, along with possible memory budget optimizations made by the developers. Back when doom3 came out there were people trying to figure out why their top of the line rendering pipelines showed pixelization etc. It was because the art was too small to be scaled that high. – Yorik Aug 28 '15 at 17:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.