4

From what I can tell, the Heavy Zerrikanian Fire Scorpion card is only available from a merchant in Lindenvale (link here). I found the guy, that's not the problem. But I can't talk to him. The prompt never even pops up. This is the guy (not my picture though). Anyone have a solution to this issue?

Lindenvale merchant

  • According to this link, that card is in Midcopse. – vianna77 Aug 28 '15 at 3:28
  • 1
    It seems that the PS4 cannot handle to load every resource etc at the same time.. if you ported there, you've to wait a while before you'are able to talk to the merchant – Nitro.de Aug 28 '15 at 5:57
  • I didn't. Rode from Crow's Perch (started a new game+ and hadn't discovered it yet). Also, the most I've seen this delay is about 5 seconds (almost always less), not 5 minutes. But I suppose I'll just try to reload an earlier save, try again, and wait longer. – Broots Waymb Aug 28 '15 at 13:28
  • 1
    I had that problem with a blacksmith... I meditated for 1 hour and tried again. And then it worked. – vianna77 Aug 28 '15 at 14:00
  • I don't recall trying that, I think I just stood around for a while. I'll have to give that a shot. – Broots Waymb Aug 28 '15 at 14:01
1

I had to combine a couple methods before I was able to talk to the merchant. I'm guessing I just had an extra buggy game, since I talked to a couple people who didn't have an issue with the same merchant. Basically, I saved before going to him, then meditating for a little bit, and finally just decided to run around for a minute or so and when I came back, I could talk to him.

I can also confirm this is where the Heavy Zerrikanian Fire Scorpion card is.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.