5

Short version: I made a custom TF2 stock Scattergun model, and I'm trying to get it to work in-game. I'm modifying the v_model for the Scattergun (models/weapons/v_models/v_scattergun.mdl), and it works when I use HLMV, but it doesn't work in TF2.

More info: I placed it under my tf/custom folder, as tf/custom/newmodels/models/weapons/v_models/v_scattergun.mdl. However, when I load it in TF2, the model is the same as the default Scattergun.

I thought maybe it was the Scattergun that had a problem, so I chose the Bat (another v_model), but that didn't work either. I also thought maybe the models were unused (since most of the weapons are c_models), so I made a w_model version of the Scattergun, but it still didn't work, and the world model was still the same. I even tested it on my own server with sv_pure set to 0, but all I saw was my default Bat and Scattergun.

I went back and checked my files to make sure the model was compiling properly, and it was. I even tried deleting any extra unused files I had in the model's folder, but nothing changed.

What's going on? I know I'm placing the models in the correct location, since I made a flamethrower and it works fine in-game. HLMV also shows the model properly, it's just TF2 that doesn't show the model.

Is there something I'm doing wrong, or do the v_ and w_ models no longer work?

  • Check the sv_pure setting of the server you are playing on. – user973 Aug 29 '15 at 19:40
  • @MadMAxJr I did, and it was set to 0. I've edited the question to include this. – ASCIIThenANSI Aug 29 '15 at 22:46
2

Apparently the Scattergun was changed to use a c_model in the Love and War update.

Source

1

You're using an incorrect folder structure.

In order to replace a model, the folder path must match the path listed in the applicable .gcf file following your mod folder name. The correct directory you want to use is:

tf/custom/my_mod_name/models/weapons/v_models/v_scattergun.mdl

  • I moved it to the correct location, but it still doesn't show up. – ASCIIThenANSI Aug 29 '15 at 23:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.