3

I bought Empire Earth - Gold Edition on GOG last night, assuming that it would work on Windows 8. Every time I load in, I get maybe 30 seconds in the various menu screens, before the whole thing locks up for reasons I can't understand.

I've made sure I'm using my nVidia graphics card, not the integrated Intel one. I've installed the NeoEE patch, tried changing the rasterizer, setting it to not wait for vsync, tried compatibility settings, restarted my machine, uninstalled and reinstalled, tried running it using the 3D-Analyser, but it still just freezes on the menu screen. I tried deleting the DirectX dll files, but then it just causes the entire thing to crash when AOC is launched. Every other problem I see when searching is about graphics issues, or the game just crashing as soon as it is launched.

Please tell me there is a solution for this menu freezing. As it stands, I can't even start a game without the entire thing locking up.

  • @DeleteMe, the text, to me, looks fine. On the other hand, your comment is a good example of poor grammar. Could we presume the issue is in your ability to interpret the body? OP is asking a very clear question.. Empire Earth freezes at the menus on Windows 8. Can this be fixed – user106385 Sep 9 '15 at 2:09
  • have you tried the "edit registry" solution? A quick stroll on the EE Heaven forums tell me it is not windows 8 compatible, but a user has posted a fix that others have reported to work quite well. – user106385 Sep 9 '15 at 2:18
  • 1
    Yeah, I've tried that, that's setting the rasterizer and disabling waiting for vsync. Didn't help – JamesENL Sep 9 '15 at 2:18
  • 1
    Did you contact GOG support with this also? They might have some solutions with this too since they tested the games – donis Sep 9 '15 at 7:54
  • I'll give that a shot tonight :) Thanks for the suggestion. – JamesENL Sep 9 '15 at 8:03
0

I fixed this issue, not 100% sure exactly what was the fix, but I'll post the details of what I did so that if someone else has this issue they can try what I did to fix it.

  • Changed the Rasterizer and Wait for V-Sync options in the registry.
  • Installed the game again.
  • Installed the patches from here first then the patch from here
  • Set the V-Sync Mode in my nVidia control panel to Application Controlled, and made sure that the game was using my nVidia graphics card rather than the integrated Dell graphics card.

The menu didn't freeze up and I'm so happy that it works! Hopefully this can help someone else in my situation.

|improve this answer|||||
0

I have the same problem but I wanted to add to the accepted answer under point 1 because it isn't 100% clear for anyone else facing this problem:

from e10hs @ee.heavengames.com:

you need to edit a registry value (winkey+r, type 'regedit' and press enter): change: "HKEY_CURRENT_USER\Software\SSSI\Empire Earth\Wait for VSync" From 1 to 0. Also, change "HKEY_CURRENT_USER\Software\SSSI\Empire Earth\Rasterizer Name" to: "Direct3D Hardware TnL" - copy the exact text wihout the "

I was unable to install the patches you linked though. An error came up both times, saying that it couldn't find something, and the installation quit.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.