2

Using Steam, when I try to reinstall one of my games, it always says "Disk write error". I went to content_log to go to the specific place and gave full access to all of my computer like a guide told me to but it still says "Disk write error". I have scanned my drive and moved the game over to my SSD and back. It still doesn't work. I am using Windows 10. What should I do?

2

Open a Command Console with Administrator Privileges by right clicking on your start-menu button and selecting the entry for it.

Then enter the following command:

CHKDSK D: /F /R /B 

Replace D: with the corresponding letter of the drive that is problematic. Do NOT use this command on your SSD. It is also very likely that this will make Windows ask you if you want to take the Volume offline while scanning. Close all programs that live on that drive to avoid being forced to do a reboot. However, in some cases you will have to do a reboot so this command can run without interference. This can also take several hours to complete, so it is wise to do this during the night or while at work.

If that does not solve the problem, there is a software called EaseUS Partition Master which has a feature called "Surface Test". This procedure has the ability to mark bad sectors so the OS will not try to write to those anymore.

The ultimate solution, however, would be to buy a new HDD in the near future.

| improve this answer | |
  • I've tried doing the check disk with administrator controls and it gets stuck on 10/11%. I've deleted a bunch of Steam games to shorten my hard drive space out by like 600 GB. It still won't work. – Mr McClean Sep 12 '15 at 17:58
  • Doing the surface test now. – Mr McClean Sep 12 '15 at 18:16
  • The surface test froze about 92% on the way there and found 1 bad sector. I might have to restart the surface test and do it at night again. – Mr McClean Sep 13 '15 at 14:19
  • 1
    Your drive is dying. Backup NOW. – Nelson Sep 13 '15 at 14:22
  • @Nelson Ok thank god for CrashPlan being installed. I am keeping my self backed up. – Mr McClean Sep 13 '15 at 16:27
-1

Opt out of steam beta. Do so by clicking settings, account, change steam beta to None-opt out of all beta.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.