8

The Battle.net Launcher (and Hearthstone: Heroes of Warcraft) were working great for me under Wine 1.7.15 through PlayOnLinux up until a few days ago. Now whenever I start the Battle.net Launcher I get the following error:

Battle.net requires the Windows Secondary Logon service to be enabled. Please click the error code below for instructions on enabling it.

More Help: BLZBNTBTS00000025

I followed that link and the solution understandably applies only to Windows, and not to Wine. I've also read through the solutions so far on the PlayOnLinux forums, which suggest the following:

Just a heads-up: For some reason, if I hit "debug" in Playonlinux instead of "run" it brings up the Battle.net login screen and lets me log in. It then lets me launch Hearthstone. I can then quit Hearthstone, close Battle.net, then hit "run" in Playonlinux and it launches fine.

and

In my case using stock wine-1.6.2 I had to enter winecfg and change the library dbghelp from "disabled" to "native" and it opened right up.. in the past it wouldnt open without it disabled so it is likeley that this is the configuration playonlinux is still using.

Unfortunately neither of those solutions fixed the issue, and I am still seeing the Windows Secondary Logon service error. Here is a screenshot:

Battle.net Error Screenshot

Just trying to get Hearthstone running again. Thanks!

11

1) Launch Battle.net

2) Leave the window with the error message open

3) Launch Battle.net again

It's a strange workaround, but it worked for me every time so far.

  • 2
    SO SAD. Works for me too :( I kind of wish it hadn't... – Ramon Snir Sep 12 '15 at 12:40
  • 1
    Wow, I can't believe this works - it feels like cheating. Ideally it would be nice to have a solution specifically for PlayOnLinux that bypasses the error altogether, but this is a fantastic workaround. – Maximillian Laumeister Sep 12 '15 at 19:04
  • Thank you again for this workaround! I'm going to mark this accepted until when/if someone finds a PlayOnLinux solution that bypasses the error entirely. – Maximillian Laumeister Sep 14 '15 at 3:09
  • This did not work for me. The second copy of Battle.net does not show the error, but the main window is completely white. See imgur.com/AQzyeDb . – WhyNotHugo Sep 14 '15 at 4:29
  • 1
    Works for World of Warcraft for wine (not PlayOnLinux). – Charity Leschinski Sep 16 '15 at 0:55
4

I had to enter winecfg and change the library dbghelp from "disabled" to "native" and it opened right up. Unfortunately neither of those solutions fixed the issue

I had the same situation when I tried the override in that battle.net.exe would still fail because I did not have the native dbghelp.dll installed.

Using winetricks on my dedicated battle.net wine prefix installed dbghelp as a native override. But this causes all applications to use the native library which is strongly advised against.

My full process was:

  1. Installed dbghelp with winetricks to my wine prefix containing battle.net and my Blizzard games (This will download a Microsoft patched version that may require you have a valid Windows XP license!)

  2. On winecfg for the battle.net wine prefix I removed dbghelp from the generic list of overrides by deleting the entry

  3. In winecfg for the battle.net wine prefix I created the battle.net.exe application

    • added dbghelp to the override
    • clicked on okay to the pop-up warning about the dbghelp override being a bad idea
    • clicked on edit and set dbghelp to just (native) in the pop-up box
  4. Made sure no other wine instances were running with the old setup using wineserver -k

  5. Successfully started battle.net

  6. Successfully started a game (Diablo 3)

  • Setting the override for battle.net.exe (and also battle.net launcher.exe) did not work for me. Setting it as a global override did work. Why is this latter option not advised? (I'm using an SC2-specific prefix). – WhyNotHugo Sep 14 '15 at 4:34
  • For some reason none of these solutions work for me. I feel like I must be doing something wrong. I'm running 1.7.15 via PoL and was able to install dbghelp with winetricks and set it to native, but still no go. I can't even do the trick where you run two copies of B.net. The second one never opens for me. I don't even get to the white screen. – Two-Bit Alchemist Sep 14 '15 at 23:08
-1

Open winecfg and change the emulated windows version to Vista, Blizzard is removing support for XP. Secondary Login Service didn't exist until Vista's release.

  • 1
    I tried changing the version first to Vista, then to Windows 7, and the error still occurs. – Maximillian Laumeister Sep 14 '15 at 2:38
  • Have to tried rebooting? Not sure if wine can change versions if it's happens to be running. – Nightness Sep 14 '15 at 2:48
  • Also, I'm using wine-1.7.44, check your version with "wine --version". – Nightness Sep 14 '15 at 2:49
  • I stopped all running applications in the prefix using PlayOnLinux. You're saying though that you got the error when your setting was on Windows XP, but now that you changed to Vista you aren't getting the error anymore? By the way I wasn't the one who downvoted you. – Maximillian Laumeister Sep 14 '15 at 2:50
  • 1
    The launch then relaunch seems to be the only way... My guess Secondary Login Services isn't running right away, so after some wine application is started, it starts too. – Nightness Sep 14 '15 at 5:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.