2

I've looked at a few other questions on here about this, but I still can't get this to work. I've already looked at this: Clear item with custom name?

I'm trying to clear a custom item (just one) from a player's inventory through a command block.

Here's my command:

/clear @p gold_ingot 0 1 {display:{Name:"Stamped Gold Bar",Lore:["One Gold Bar","Stamped on site at Acacia Mint"],,ench:[{id: 34, lvl:1}]}}

Here's my error message:

[00:37:53] Removed 0 of gold_ingot from Jowaaay.

Even if I just do /clear @p gold_ingot, it will not remove my custom gold ingot, and will still give the same error message. I tried putting regular gold ingots into my inventory just to test that I had the correct syntax, and regular items do seem to cooperate with the /clear command.

I followed the advice given by the user who solved the above question, but I still can't get this to work. Wondering if it has to do with the enchantment on the gold ingot?

I'm running a Bukkit server with a 1.8 Minecraft. I do have Essentials installed, but I don't see how that would affect this.

6
  • Isn't that 0 value in your command the quantity, meaning that you've set the quantity of items to be removed to none?
    – user114997
    Sep 17, 2015 at 7:14
  • @Texenox the 0 is the damage value of the ingot, and is fine.
    – MrLemon
    Sep 17, 2015 at 8:08
  • 1
    Your data tag is ill-formatted, you need to close the display tag before starting the ench tag, i.e. the ending should be ...Mint"]},ench:[{id: 34, lvl:1}]}. Although I don't think this is the issue. The error message you are getting is not normal for the clear command. I suspect you are accidentally running Essentials /clean//clearinventory command, rather than the vanilla /clear. That would explain the ill-formatted message, and the removal of 0 items.
    – MrLemon
    Sep 17, 2015 at 8:10
  • Personally, I would set the damage value to -1, which matches against all damage values.
    – MBraedley
    Sep 17, 2015 at 21:07
  • Okay, so I tried this: minecraft:clear @p gold_ingot -1 1 {display:{Name:"Stamped Gold Bar",Lore:["One Gold Bar","Stamped on site at Acacia Mint"]},ench:[{id: 34, lvl:1}]} And now I'm getting this error message: [22:47:20] Could not clear the inventory of Jowaaay, no items to remove I fixed the formatting, I made the command a vanilla command, and I changed the damage value to -1. So strange! Sep 19, 2015 at 3:50

1 Answer 1

1

First you need to close the display:{} tag then remove the extra comma. So it should look like this:

/clear @p gold_ingot 1 0 {display:{Name:"Stamped Gold Bar",Lore:["One Gold Bar","Stamped on site at Acacia Mint"]},ench:[{id:34,lvl:1}]}}

This will most likely work, I'm not sure though.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .