6

I have a Windows 10 virtual machine (using Parallels Desktop v11) on my Mac (OS X Yosemite). I wanted to use my F510 gamepad with a game. So I did these things:

  • Installed the Logitech Gaming Software on both the Windows and Mac sides (there are no driver downloads listed, only the Gaming Software is required)
  • Checked to see if the gamepad was recognized on the Mac side - in both X and D mode, yes:

mac verification

  • Checked to see if the gamepad was recognized on the Windows side - no, not in X mode or D mode (besides, the game I need to play it with only supports X mode)
  • Checked to see if it was in the Windows 'Devices And Printers' - no
  • Tried to use the 'Devices' menu in Parallels Desktop to connect it - wasn't even there
  • Checked to see if the Logitech Gaming Software on the Mac side recognized it; surprisingly no:

logitech mac

  • Checked to see if the Logitech Gaming Software on the Windows side recognized it; unsurprisingly no.

And now here I am. Does anyone know how to do this?

Thanks in advance!

EDIT: When I check around some people are suggesting running the Gaming Software (Mac side) as admin. However, this also doesn't work: No devices detected again.

EDIT: It turns out that the only version of Parallels that's compatible with Windows 10 is v11. I had v10. I shelled out some money to update and tried again - still nothing.

EDIT: So I then thought, maybe this is a bug with Parallels Desktop itself, so I used VirtualBox to create a new virtual machine using the existing .hdd file. After all of that, I tried again - and still nothing happened. At this point I've no idea what else to try.

1
+100

Simple. All you have to do is restart you entire computer (not just your virtual machine), then you unplug your gamepad, plug it back in, and it should recognize it. (if not, try checking to see if the USB is dirty on the inside or something)

  • and if THAT didn't work, honestly just get a new gamepad – Tangela Tube Jan 16 '18 at 17:26
  • 1
    Actually, there is a setting in the virtual machine software loader (or whatever you use) that lets you use USB devices on it. I use virtualbox, and there is a setting for it in mine, so if you dont use virtualbox then i dont know what else to say. – Tangela Tube Jan 16 '18 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.