2

The horse I bought from the stables next to Whiterun starts to walk away when I dismount it. I bought another horse to fix this problem. It is the palomino one from one of the northern Holds. This one does not run away when I dismount it, but the other one still does. Is there any way to fix this?

I know it is not necessary to fix the Whiterun horse since the other one is working, but I'm just curious as to why this is happening. I have tried loading previous saves, but that hasn't worked.

2

Fix 1

According to the UESP:

Only the horse that you last rode will travel with you. Horses you bought will return to where they were purchased as soon as you mount a different horse, while horses obtained as quest rewards will stay where you leave them.

See if you go back to Whiterun Stable, you can mount your horse and it will be loyal to you.

Fix 2

A way to fix this is to target the horse in the console, then type:

disable

and then

enable

Fix 3

You can also try to target your player and then use setownership <ID>

With ID being the Horse's ID.

From the UESP:

You can set the owner of the targeted item with a faction ID or a character's base ID. If you don't add the parameter, the default owner would be yourself. This can be used to remove the "stolen" tag from any items. Simply drop the item on the ground, open the console, click on the item, and enter the command. It can be difficult to select certain items. If the displayed ID code does not begin with "ff", you have not selected an item, but rather an object in the world (ground texture, light, container, etc.). Can also be used to remove the "owned" attribute of beds and gain the ownership of a stolen horse.

Why it might happen:

There is a couple of things that can go wrong here:

  • The ownership has not been set properly (fix 3)
  • The AI of the horse does not recognize your position (fix 1 or 2)
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.