I'm stuck on the Dragon Rising quest. I've already killed the dragon and it tells me the next part is to investigate the dragon. I've already done that, but it doesn't change or update the quest. All Whiterun soldiers that were with me in the quest are still ducked down just as they did to prepare for the dragons plummet as it died. What can I do to move on from it without going back to a previous save? I've already tried resetting the quest but that's not working at all.

  • 1
    What did you do to "reset" the quest?
    – Nelson
    Commented Sep 22, 2015 at 1:02
  • Did you absorb the soul? As far as I know, the quest will advance as soon as that happens. Commented Sep 22, 2015 at 5:13

4 Answers 4


Unfortunately, by "investigating" dragon you're supposed to absorb it's soul. If that didn't trigger the quest advancement then you have 2 options:

  1. Reset quest by loading save where it hasn't started / restart game.
  2. Use Console Command "setstage" to advance the quest

    2.a. Open Console and use "setstage MQ104 90" to get past "investigate dragon" (stage 80).

    2.b. Use "setstage MQ104 160" instead to complete the quest.

Dragon Rising Quest


just discovered, that if you didn't get the dragon soul and you are too far away the dragon will follow you and fall/faint/die again and if you leave it again you will come back with the dragon covered by dirt

  • Yeh, dragons following you has been an issue. It has been fixed by the unofficial patch. Commented May 12, 2018 at 3:49

After unsuccessful attempts trying everything I came across, I found this on Fandom. Simple is best. Worked like a charm.

Credit to Scottb413, posted on 8/25/2016:

I have Legendary and had the same problem stuck on first dragon could not absorb soul. After a huge amount of looking around I finally fixed it. Here's how:

Go to C:\Users\your name\AppData\Local\Skyrim (Make sure to show hidden files first as this folder is hidden.)

Then you will see 2 files DLCLIST and PLUGINS. All you need to do is make sure your patches are in the right order.

This is how I have mine and it fixed my problem:

Unofficial Skyrim Patch.esp Dawnguard.esm
HighResTexturePack01.esp HighResTexturePack02.esp HighResTexturePack03.esp Unofficial Dawnguard Patch.esp
Unofficial Hearthfire Patch.esp
Unofficial Dragonborn Patch.esp
Unofficial High Resolution Patch.esp

Make these changes to both files.


I had the same problem. I fixed it by entering setstage MQ104 90 in to the console.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .