4

Whenever I travel to a city that is controlled by Imperials I get attacked by all of the guards and I don't know why. I'm Stormcloak, but normally imperials don't attack me.

I am dressed in Daedric Armor and I'm not a vampire. However, I am a werewolf but I have only a 40 gold bounty which shouldn't be enough to provoke them to attack me so I don't know what the problem is.

I have searched Google & Skyrim Nexus for a way or a mod to fix this but no luck. Does anyone know how to fix this?. I am still in the process of trying to find a fix for this very annoying bug.

1
  • 3
    Missing a LOT of context: Bounty? How far along in quests? Vampire? Werewolf? Stole a lot of stuff?
    – Nelson
    Sep 23 '15 at 6:35
4

This has a tendency to happen quite a lot. If you are some way into the campaign on either side, then you will be a known member of that faction. In other words; After a certain mission, you will be attacked by the opposite faction.

This will stop after you have completed the missions from that faction, so try to do this as quickly as possible.

As said by John, it could also be because you are wearing the equipment set of the opposite faction, which will also cause them to attack you.

1
  • 1
    yeah i was thinking that but didn't know if it was true or not. i am up to the part where you have to deliver false documents to a legate in morthal but i can't do that because all the guards attack me. Sep 23 '15 at 8:03
3

It's probably not a bug. You are probably dressed as a Stormcloak when you enter the city, or as that guy suggests, you become recognizable as a Stormcloak after progressing past a certain point in the civil war. Dressing as an Imperial will allow you to enter Imperial cities, but you'll then have the same problem in Stormcloak cities unless you change back. There is a Master of Disguise mod that allows subtler effects, tying your Disguise ability to both clothing worn and Stealth skill. I use it, but it now seems to be missing from Nexus. I see at least one other disguise mod still available that may help you complete your current mission, but I haven't tried any other disguise mods, so I can't recommend one.

It's possible, though, that there are other explanations for the behavior, for example severe vampirism or a bounty. Since you didn't provide much information on which cities are definitely affected, how you confirmed, how far along in the civil war you are, or whether you have been turned into a vampire or joined the Companions, it's hard to say for sure what might be happening. Make sure you don't have a bounty in any of the affected cities and that you don't have vampirism. Also, if you still suspect a glitch, try leaving the area and waiting a week before returning.

1
  • 1
    ah sorry forgot to add that stuff. i am a werewolf and was dressed in full daedric armor and i have a 40 gold bounty in eastmarch which is dragon bridge i think which i do get attacked at.i sheathe my sword but only one guard stops attacking me, i pay off the bounty but i still get attacked Sep 23 '15 at 7:43
0

My advice, go wipe out General Tulious (sorry for messing his name up) so they stop attacking you. This might solve your problem once and for all.

The harder way is to sneak past all of them and get the documents that way

-1

Try putting your weapons down.They will probably stop and attempt to put you in prison.Or maybe complete the stormcloak quest line so the imperials will be almost wiped out.Hope this helped!😜

1
  • yeah see thats the problem, even if i do sheathe my weapons they still attack me except for one guard that wants me to pay off a 40 gold bounty which i did and they still attack me this makes it impossible for me to complete the stormcloak questline Sep 23 '15 at 20:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.