1

I hope some of you might know the really old game called Anno 1602.

It is working on my home computer without any problems. Today I tried to connect to it over Windows Remote Desktop and I get the error: "SetDisplayMode failed. Please check if your windows display is set on 256 colors." I know that this is because Anno is a really old game. But as I said, at home it works perfect and now over remote I get this error.

Maybe it is possible to change something in the remote settings with the display?

1 Answer 1

1

Sadly I cannot comment on this due to lack of reputation. I believe your issue may lie in mstsc.exe painting the screen.

When you can, see what colour depth your screen is set to (32/16). You can then configure the RDP icon to run at that. By default, the highest quality is 32 bit.

Press Windows + R and enter mstsc.exe and hit enter. Select more options and then display. Change colours to either 24 or 16 and try. Let me know how you go.

2
  • 1
    I have tried every option there. but it didn't worked. But i have installed teamviwer and with it it is working perfectly...
    – TheEquah
    Sep 28, 2015 at 7:22
  • @TheEquah if that's your valid fix for the solution, Mark it as your answer please.
    – DankyNanky
    Sep 28, 2015 at 7:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .