1

I have had Shogun 2: Total War for a a few years now and am now pulling the game back out. The other night, I played with full-size units, and it worked just fine - like it always has on my computer. Today it's trying to limit me to small- or medium-size units for no apparent reason, and the large option is gone.

Why would it suddenly take that option away on the same machine it's always been to work on without any trouble (including the other night)? What is a way to fix this that doesn't involve mods or hacking around the game? Thank you.

(In particular, I know that there's some sort of scripts file with a multiplier in it, but I want to avoid this and change it back in-game if possible, to avoid possibly blurring the lines between whether a cheat is being used or not. However if it wouldn't be any different at all mechanically from setting it to large in-game, or if there were a way to just force medium graphics options or something to be available in-game, that would be fine.)

UPDATE

There is apparently a way for most people to unlock graphics menu options by simply typing in a hard-coded number of bytes in the graphics memory field of their preferences script (I don't have the exact names of everything with me, but this has apparently come up a lot); but for me and for some other people, this isn't working, even if we block the preferences script file from being edited by the game.

(This would completely make sure none of the game mechanics are out of order, which is almost the whole reason I haven't simply set the unit multiplier in the scripts file. Maybe it would be legitimate as long as I just set it to either 0.25, .5, 0.75, or 1?)

I also tried to simply adjust the amount of dedicated video RAM in my BIOS to unlock the graphics options, but my Intel Graphics HD card doesn't provide much room for that.

  • 1
    It could be that in a patch the developers changed the requirements for certain graphical options. The other thing to check is that your PC is still reporting its actual spec's and something is not underclocked / displaying incorrect info. – kenjara Sep 29 '15 at 7:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.