I've tried a large number of solutions to the problems that 64 bit Windows 7 has with Generals and Zero Hour, to no avail. I've been trawling all over the internet for a fix for my problem.

To wit, I've properly created the options.ini file with proper file type as well as altering the resolution to match my desktop resolution. I have changed the properties on the game launcher to grant it admin privileges and run it with XP 3 compatibility enabled. I have changed both the base install folder and the data folder in documents to disable read-only access.

Notably, I have not been running into the same errors as everyone else I have been reading as running into. My problem is that before granting permission to run in XP 3, the game explicitly tells me it could not launch and to try running it in an older compatibility. After enabling this, attempting to launch the game simply does not work, no error report or anything. Generals.exe simply vanishes within a few seconds.

There are a lot of other fixes I have tried but cannot remember for their comparative obscurity. I updated directx to be sure, and my graphics drivers are up to date though after an issue installing an update a month ago my driver kernel occasionally freezes up while I am watching videos in my browser.

I'm clueless as to how to get Generals working. I would really love to have it running so I could play some of the excellent mods for it.

The reason that this game no longer works is outlined by the other answer and this other question on Arqade. Basically there was a security hole in Windows 7 and 8 that Microsoft patched that makes certain write protection not work anymore. There is a simpler and safer solution to the problem than the one outlined in the other answer though (note that there is no workaround for Windows 10). First, open a command prompt as an administrator:

Windows button -> cmd.exe -> right-click -> Run as administrator

Run this command (with the exact spaces) to reenable the driver's service:

sc config secdrv start= demand

You should get a [SC] ChangeServiceConfig SUCCESS message. Then run this command to start the service:

sc start secdrv

Then open the game and it should work! You'll have to start the service every time you want to run this or any other CD-based game with SafeDisc or SecuROM, and you'll probably want to stop it when you're done to reduce security risks.

  • 2
    This definitely brought me closer to a solution than anything else I've seen before, the game launched but a serious error occurred afterwards. I think this solution ought to work out for most people though, and might just require doing the things others have suggested too. – Etzel Dec 15 '15 at 22:23
  • 1
    worked for me, windows 8.1 64 bit c&c general with daemon tools lite – Iftikar Urrhman Khan Jan 14 '16 at 15:44

I have Windows 7 64-bit as well. Generals did work on my computer at some point but no longer worked for a while. I did try all the fixes you mentioned, and I eventually found out that my problem was caused by a Windows update, specifically, Update KB3086255. Here's a link to show you how to uninstall the aforementioned update:

  • @Texenox What relevant information could he possible have added? how to remove a windows update from your update history? – senpai Oct 27 '15 at 22:36
  • @Texenox This question is not "How to uninstall a Windows update", though. They can look that up somewhere else. – Nyerguds Feb 7 '16 at 23:56

Following the instructions on forums.cncnz.com worked for me. I already had the latest drivers and I installed C&C Generals and Zero Hour. Then (these are I think the most important parts):

  1. Try to run C&C. It will not work but it will create this directory: C:\Users\<your user name>\Documents\Command and Conquer Generals Zero Hour Data.
  2. In this directory, create an empty file called options.ini.
  3. Copy these contents to the file:
AntiAliasing = 1
BuildingOcclusion = yes
CampaignDifficulty = 0
DynamicLOD = yes
ExtraAnimations = yes
GameSpyIPAddress = 0.0.0.0
Gamma = 50
HeatEffects = yes
IPAddress = 0.0.0.0
IdealStaticGameLOD = Low
LanguageFilter = false
MaxParticleCount = 5000
MusicVolume = 55
Resolution = 1366 768
Retaliation = yes
SFX3DVolume = 79
SFXVolume = 71
ScrollFactor = 60
SendDelay = no
ShowSoftWaterEdge = yes
ShowTrees = yes
StaticGameLOD = Custom
TextureReduction = 0
UseAlternateMouse = yes
UseCloudMap = yes
UseDoubleClickAttackMove = no
UseLightMap = yes
UseShadowDecals = yes
UseShadowVolumes = yes
VoiceVolume = 70
  1. In Windows Explorer, go to C:\Program Files (x86)\EA Games\Command & Conquer Generals Zero Hour.
  2. Right-click on generals.exe. Select Properties.
  3. On the Compatibility tab, check Run this program in compatibility mode for and in the drop down select Windows XP (Service Pack 3).
  4. On the same tab, under Privilege Level check the Run this program as administrator check box.
  5. Press OK and then run the program.

So far this crashed once (with a "serious error" when I changed the settings in game) - apart from that it has worked fine.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.