2

I can play and host other maps just fine, but whenever I try to play the 2015 Halloween event, Invasion, the map loads to about 80% and then hl2.exe crashes.

I made sure to have enough free RAM and HDD space, and verified my cache.

64-bit Windows 7 Home Premium on Intel i5 750 @2.67GHz
NVIDIA GeForce GT 220 (driver 9.18.13.4181) OpenGL 3.3
Primary Display Resolution: 1680 x 1050
Primary VRAM: 1024 MB
RAM: 12279 MB
Total Hard Disk Space Available: 9,52 GB

Despite my solutions below, 2fort Invasion still crashes while sending client info with one loading bar left. Watergate, Probed, and Byre work.

3

UPDATE 2: Using launch option -dx98 in Steam's game properties, I was able to play ctf_2fort_invasion! Trying with CRLF line endings in autoexec.cfg failed, as did 1440x900. Launch option -condebug only shows Redownloading all lightmaps as last line, and lately some warnings:

*** Encountered VTF file with an invalid minor version!
*** Encountered VTF file with an invalid full header!
Error reading texture header "materials/vgui/resource/mic_meter_live.vtf"

I revalidated my local TF2 files: no errors.

UPDATE: Without a CR character in autoexec.cfg, Watergate works fine in high res! Open it in Notepad++ or other decent editor, and convert line endings to LF-only ("Unix-style").

Old solution:

I first renamed C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\cfg\autoexec.cfg to autoexec.cfg.2014. This allowed me to auto-join an Invasion multiplayer arena game. It never got enough players, so I can't verify actual gameplay, but at least the map loaded fully. Other Invasion game modes still had the same crashing problem, though.

I then changed my video resolution from 1440x900 to 1280x768. That did the trick, and I spent a few hours playing without any technical issue.

Working TF2 Invasion resolution

This was my autoexec.cfg, with CRLF on line 1:

tf_bot_quota 4; tf_bot_quota_mode fill
bind "F9" "sv_cheats 1; echo Generating navigation data...; nav_generate; sv_cheats 0"

Trying to play with this cfg and lower res works on Byre arena, but crashes while loading the Watergate player destruction map.

  • Is there something in your 2014 config specifically that caused the crash? Did you try Verifying the Integrity of the Game Cache through Steam? – Robotnik Oct 11 '15 at 0:14
  • I've updated my posts, and will try again with the cfg. – Cees Timmerman Oct 11 '15 at 0:17
  • It's definitely either one that causes problems. – Cees Timmerman Oct 11 '15 at 0:23
  • Weird that the CR char would cause problems. – Robotnik Oct 11 '15 at 1:31
  • 1
    On a related note, the other new Halloween maps stopped crashing when i moved a custom hud+model to C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\custom\disabled – Cees Timmerman Nov 8 '15 at 22:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.