0

When playing Borderlands and Call of Duty 4 on OSX (running Yosemite), the shift key toggles running, and I have to press it again to stop running instead of simply letting it go. How do I fix this so letting go of shift will cease running?

The shift as a toggle vs press/release is not a configurable option in either of the games I'm playing. On windows shift performs normally, but on OSX it does not.

I've talked to people in COD4, most of them say run is not a toggle for them. I've even talked to OSX users on there (one of them is even running El Capitan, while I'm still on Yosemite) and they say they don't have the same issue I do. Run ceases as soon as they let go of shift.

I've even tried binding sprint to other keys, but I still get the same issue where it toggles.

  • I don't know the games but my first guess would be that your keys are configurable in the settings of those games including it being a toggle or hold run. – Ivo Beckers Oct 11 '15 at 17:25
  • In Borderlands, this is actually a loose toggle. You can only toggle run on while you're moving. If you stop moving, run is automatically toggled off. – nukeforum Oct 13 '15 at 14:29
  • 2
    AFAIK, in Borderlands you can't disable sprinting while running forward. Sprint is automatically interrupted if you stop running forward (i.e. you look sideways and switch to sidestep to keep running in the same direction) or, if I'm not mistaken, fire a shot. This behavior is by design. – Orc JMR Oct 14 '15 at 3:48
  • I know for sure that cod4 has its own separated controls menu on the main menu. Sprint is located under movement. Have you tried this already or is the controls button not there? – zuno987 Oct 20 '15 at 0:37
3
+25

Lots of games have an option to change this in settings as per alexanderpas's answer. However lots of games do not have an option for this but you can still accomplish this in any game, regardless of the settings, with AHK (Auto Hotkey).

(Since you are on a Mac you will need to use an alternative to AutoHotkey, IronAHK is a cross platform rewrite of AutoHotkey so the below script should still work.)

Make sure you've installed AHK then use the below scripts to change the behavior. (you may need to change the name of the window)

To make a toggle behave like a hold (rebind sprint to end):

LShift::
    While (GetKeyState("LShift", "P"))
        Send, {End Down}  
    Send, {End Up}
Return

To make a hold behave like a toggle (rebind sprint to end):

#IfWinActive, Call of Duty
SetTimer, Toggler, 100 

$LShift::toggle := !toggle

Toggler: 
    if (toggle = true)
        Send, {LShift down}
    else
        Send, {LShift up}
Return
  • The main problem is... AHK doesn't work for Macs. – Nelson Oct 20 '15 at 0:49
  • @Nelson You're right I didn't know that. However there are plenty of alternative programs out there that do work on mac which this code could be rewritten to suit. There is also IronAHK (and on GitHub) which is a rewrite of AutoHotkey which is compatible with macs. – Aequitas Oct 20 '15 at 1:04
  • Probably should update the answer :) AHK alone is overwhelming enough for a typical user, and asking them to find an OS alternative won't help. – Nelson Oct 20 '15 at 1:08
  • I wouldn't mind using IronAHK, but it looks like their OS X bundle is 404ing at the moment. – Feng Huo Oct 20 '15 at 18:46
2

Generally, this is a setting you can change in the settings for each of the games, usually under controls, movement, and can be changed between hold to run, and toggle

  • 1
    True and I can confirm that CoD has this, not sure about BL though. – Ave Oct 11 '15 at 19:39
  • @ardaozkal Can't find it anywhere in the COD4 client. – Feng Huo Oct 11 '15 at 20:17
  • Borderlands is always toggle sprint IIRC. If there's an option for it, it should be under the Gameplay options. – Hugo Zink Oct 20 '15 at 8:42
0

Is it possible you have accidentally turned on Sticky Keys?

You can disable Sticky Keys by choosing the Apple menu > System Preferences, click Accessibility, then click Keyboard. Disable Sticky Keys and see if the problem goes away.

  • Nope, this was one of the first things I tried. – Feng Huo Oct 20 '15 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.