5

I just installed Minecraft on my Ubuntu system using the Minecraft Installer Peeps PPA. When Minecraft finished downloading and was launched, it crashed and this is what I got:

    ---- Minecraft Crash Report ----
// Daisy, daisy...

Time: 10/12/15 5:25 PM
Description: Initializing game

java.lang.ExceptionInInitializerError
    at ave.ar(SourceFile:560)
    at ave.am(SourceFile:361)
    at ave.a(SourceFile:310)
    at net.minecraft.client.main.Main.main(SourceFile:124)
Caused by: java.lang.ArrayIndexOutOfBoundsException: 0
    at org.lwjgl.opengl.LinuxDisplay.getAvailableDisplayModes(LinuxDisplay.java:951)
    at org.lwjgl.opengl.LinuxDisplay.init(LinuxDisplay.java:738)
    at org.lwjgl.opengl.Display.<clinit>(Display.java:138)
    ... 4 more


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- Head --
Stacktrace:
    at ave.ar(SourceFile:560)
    at ave.am(SourceFile:361)

-- Initialization --
Details:
Stacktrace:
    at ave.a(SourceFile:310)
    at net.minecraft.client.main.Main.main(SourceFile:124)

-- System Details --
Details:
    Minecraft Version: 1.8.8
    Operating System: Linux (amd64) version 3.19.0-30-generic
    Java Version: 1.7.0_79, Oracle Corporation
    Java VM Version: OpenJDK 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 67187144 bytes (64 MB) / 158736384 bytes (151 MB) up to 1060372480 bytes (1011 MB)
    JVM Flags: 5 total; -Xmx1G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    Launched Version: 1.8.8
    LWJGL: 2.9.4
    OpenGL: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.
    GL Caps: 
    Using VBOs: No
    Is Modded: Probably not. Jar signature remains and client brand is untouched.
    Type: Client (map_client.txt)
    Resource Packs: 
    Current Language: ~~ERROR~~ NullPointerException: null
    Profiler Position: N/A (disabled)
    CPU: <unknown>

Does anyone know why this is happening? Thanks.

8
  • Have you installed openJDK?
    – Aequitas
    Commented Oct 13, 2015 at 0:35
  • @Aequitas Yes, I have openJDK installed. Commented Oct 13, 2015 at 0:49
  • the latest version? and you can try updating drivers see if that helps
    – Aequitas
    Commented Oct 13, 2015 at 0:53
  • update lwjgl or this guide (same thing just different guide)
    – Aequitas
    Commented Oct 13, 2015 at 0:55
  • I tried updating lwjql but it didn't work. Commented Oct 13, 2015 at 1:15

4 Answers 4

2
  1. Looks like it's an OpenGL issue. Try sudo aptitude install freeglut3
  2. Check if you have the appropriate backport in your sources.list. I think that Debian's wiki explains it better.
  3. Check if you have OpenJDK 8 sudo aptitude install openjdk-8-jre
  4. Uninstall OpenJDK 7 sudo aptitude purge openjdk-7-jre
1

It seems like you're missing XRandR. You can get it by running:

sudo apt-get install x11-xserver-utils

For details, see this forum thread.

3
  • Actually, I have it installed. When I typed in that command into terminal, it said I already had the newest version, so nothing was installed. Commented Oct 14, 2015 at 2:22
  • Huh, and xrandr works fine and prints out some displays? That's odd.
    – Schism
    Commented Oct 14, 2015 at 18:23
  • I can confirm that with a VERY similar crashreport, with Mageia 6, and with NVidia proprietary drivers installed and working, that installing xrandr fixed an "OpenGL: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread." problem.
    – kbulgrien
    Commented Jul 19, 2017 at 2:25
0

If I recall correctly you need Java 1.8 to run Minecraft 1.8 (and annoyingly you need Java 1.7 for Minecraft 1.7). I ran into a similar problem on my system (Arch Linux) a while back and I think that's how I fixed it. Search Java in the software center and the 1.8 version should come up, if not you may need to add a ppa since you're on an older version of Ubuntu.

3
  • I updated my Java version to 1.8.0_60 but the game still crashes? :/ Commented Oct 14, 2015 at 4:12
  • 1
    You are wrong with MC 1.7, It works normally with Java 8...There was just one issue with Forge, what blocked using Java 8 on 1.6.X and early 1.7.X versions, but that got fixed years ago, too...There is not really problem to run MC 1.7 with Java 8. Commented Oct 14, 2015 at 7:30
  • ohh, oops! I guess the only time that I tried running M.C. 1.7 with Java 1.8 was with Forge installed.
    – gibson
    Commented Oct 27, 2015 at 3:17
-2

It's probably you have too many apps or u need to get an unknown (to u) update. Or both. I've experienced that before and to manny apps on that divice is always my problem. Delete some apps and try again!!;)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .