4

(Also happens on Laptop, so not just steam link)

Hello! I pre-ordered the steam link/steam controller through the steam website and just got it on Friday, but I'm having some issues.

Problem:

I'm loving the steam controller but my problem lies with the steam link. I've been trying to stream Gone home, Binding of Issac: Rebirth, Star Wars Battlefront II, and Skull Girls but all of them will not stream over 30 fps. Gone home doesn't even go past 25 fps. Though Bioshock Infinite, Half life 2, and Tomb Raider (2013) can run above 30 usually 40s to 60s.

I was using the "Display Performance Information" option while streaming and took a screenshot while playing Star Wars Battlefront II. I've attached a picture of the output. http://i.imgur.com/WPsBMbQ.png thought it might be the two Ethernet Switches that I have in between my main computer and the steam link but I connected both to a Gigabit Ethernet Switch, used only Cat 6 cables and got the same results.

Information about my setup:

  • Every switch that is in my house is a Gigabit Ethernet switch.
  • I have an Apple Time Capsule Wireless AC/Gigabit Ethernet router.
  • My computers motherboard has a Gigabit Ethernet Jack as well.
  • I am running Windows 10 pro, GTX 780ti OC, AMD FX-6100 Six-Core 3.30 GHz, 16GB RAM.

More information:

  • I have Hardware Encoding ON, on my main computer, and have Decoding ON, when using the steam link. Having both off gives the same results, and having one on but not the other gives the same results.
  • Having changed the settings to Fast, Beautiful, or Balanced does not changed any results.

Is there any settings I have to change on my computer, or anything that I'm lacking? How do I get an output of higher than at least 40 FPS?

Thank you in advance! Also if anyone needs any information I would be happy to supply!

  • Your image link leads nowhere. – Nolonar Oct 18 '15 at 21:13
  • @Nolonar Should work now – Santosderek Oct 18 '15 at 21:18
  • Interesting issue. I've noticed the same thing with my own Steam Machine but always thought it was just a problem that would disappear later on. – senpai Oct 19 '15 at 1:22
  • @oamlyya that doesn't sound good... How long has it been going on? – Santosderek Oct 19 '15 at 3:25
  • @Dyrenex Ever since I've unboxed the one I got today. Pretty disheartening to see it's affecting other people too :( – senpai Oct 19 '15 at 3:48
1

From the image you posted your system is actually doing software encoding which is very cpu intensive and I suspect is your problem.

Since you have a 780ti install Geforce experience if you haven't already and turn on shadowplay and turn that to manual if you don't actually plan on using it. This should in theory force your graphics card to do the hardware encoding and should fix it.

You'll know it's working if you see instead of "2 threads" in the encoding printout you see NVFBC.

1

I found a temporary solution for this problem; and hopefully anyone who has this problem on Windows.

I don't have a lot of experience with encoding, but I found that the D3D9 encoder doesn't really work too well, so if you put your games in windowed mode then it'll switch to Desktop DWM RGB and output at 60 fps.

I've tested Rocket League, Gone home, and Star wars Battlefront II and they all work well!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.