6

I'm trying to beat Alduin, at the Throat of the World. But I can't hurt him!

I'm level 47 and I'm wearing all Ebony armor, the helmet is +35% for archery. The weapons I've used are Dragonbane and a Daedric bow w/ shock damage. Everything is legendary. Is this some kind of glitch?

5
  • 2
    I've beaten this guy with a two-handed woodstaff from a mod who has less base dmg than any other two-handed weapon. So this appears to be a glitch for sure. Oct 22, 2015 at 5:18
  • Not a duplicate, but the second answer to this question might be relevant here: gaming.stackexchange.com/questions/132410/…
    – psyk0
    Oct 22, 2015 at 5:44
  • Your weapon name means almost nothing. If you fight a normal dragon you meet at a word wall, can you kill it easily and readily? Alduin is MUCH harder than those dragons.
    – Nelson
    Oct 22, 2015 at 6:23
  • 1
    Did you remember to use the Dragonrend shout?
    – user79446
    Oct 22, 2015 at 8:54
  • 1
    Thanks for your answers, I exited and reloaded the game. That did the trick.
    – Clint
    Oct 22, 2015 at 13:23

2 Answers 2

6

The Elder Scrolls Wiki reports a bug similar to the problems you are experiencing.

Taken from The Elder Scrolls Wiki: Skyrim: Alduin's Bane: Bugs:

Alduin may become invincible during the fight. According to the patch notes, this bug was supposed to have been fixed by version 1.9.26.0.8 of the Skyrim Official Patch. However, there have still been confirmed reports of this bug occurring; specifically, if you exit dialogue with Alduin prematurely after returning from the vision in the Time Wound, or if you die during the fight with Alduin and reload the game. Open the console, click on Alduin, then use the command disable followed by enable. This may result in Alduin being able to be damaged normally. Saving immediately before combat starts, then fast-traveling away and returning, may fix this. As of 1.9.32.0, the game creates an autosave after exiting the Merethic-era cutscene, right before the conversation with Alduin.

-1

It happened to me when I got killed after I beat Alduin. I got nuked by like 6 of the meteors. When I loaded back in, I hit Dragonrend and started wailing on him and did zero damage between my decked out Dragonbone bow (that I beat him with the first time) 90 damage plus 25 fire. And Shadowmere + Parthyboi, not even one point of damage between us.

The only thing I tried that worked was (on PC) the command killall.

1
  • ... pretty much the only part of this answer that's relevant is the last paragraph. Nov 5, 2021 at 18:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .