8

On my MBP mid 2012, I experience some weird lag I've never experienced before. On the title screen and in-game, the game runs normally. However every 5 seconds, the sound cuts off and the game freezes for a split-second. This happens to anything moving on the title screen too. I have the FPS meter activated on Steam, however that doesn't show any change in FPS at the time of the skip.

Here is what I've tried so far:

  • I've tried Validating Game Cache, without success.
  • I've tried lowering the graphics to the lowest without success.
  • I've tried messing with all the settings regarding Video in different ways, without success.
  • Reverting Video to "Use Defaults", without success

The console shows nothing abnormal, except some 'not found' files. The full console output at the time of start, and continue game can be found here. Console recorded after Validating game cache (which showed no files that failed to validate). I would like to avoid re-installing the game.

4
  • 1
    Have you tried with Vsync on and off? Also, what operating system is it running on?
    – imulsion
    Oct 26 '15 at 11:06
  • @imulsion OS X (10.9.5 Mavericks). I tried V-Sync Triple buffered, double buffered and disabled. But that did not even affect the frequency of the skips. Also, I never had problems with this before
    – John K
    Oct 26 '15 at 11:57
  • 1
    I know you said you've tried messing with video settings but did you make sure to try and mess with the refresh rate? Make it equal to the one your monitor uses.
    – Slippo
    Jan 24 '17 at 0:40
  • Try using your video card settings to force V-Sync on the application instead of trusting the application to handle it and see if that resolves the problem.
    – CDove
    Jan 27 '17 at 18:38
2

I have done a lot of research on this topic, and this is what I found out:

It is most likely a issue with the game itself. The new update is known to cause problems with Mac users. It should have been fixed by Valve by now, though.

You could also try turning off V-Sync and Multicore Rendering, some people have reported that by doing that, it fixes the issue with Portal and L4D (but some people here have replied to your question with the suggestion for V-Sync).

I have also stumbled at many of those who suggest validating files, etc. (But you say you already did that)

The last resort is re-intalling the game.

Not the answer you're looking for? Browse other questions tagged or ask your own question.