6

In this instance, I have just finished constructing a settler, and I'm unable to select another unit/building for production. The supposedly completed settler is nowhere to be found. In the image below, you can see that there is nothing in the production list; I can't build any units, buildings, wonders, or "other". the "-" minus symbol indicates that clicking the header would minimize the list (clicking it simply shows the plus sign).

empty production selection list

SHIFT + ENTER wasn't working for me, so I can't seem to progress in this game. I've tried reloading a save file from the beginning of the turn. I moved my single garisoned unit out of my city, and that didn't fix anything.

Has anyone seen this before, have any idea what could have caused it, or know how to fix it?

  • Do you have enough technologies to give you items to build? – Fezodge Oct 28 '15 at 17:19
  • Have you tried closing the program and relaunching it? I see you've reloaded the save, but what about fully closing the program? – Michaellogg Oct 28 '15 at 17:40
  • 1
    @FezodgeIII I've and it to the medieval era, and I should be able to build something from each of the categories. – kevlarjacket Oct 28 '15 at 17:47
  • 1
    Do you happen to have, say, an autosave from a few turns before it happened? If so, is the problem reproducible? – Michaellogg Oct 28 '15 at 20:48
  • 1
    Are you using any mods? – David Harkness Oct 29 '15 at 1:16
4

I was able to find an unnoficial workaround for my case (which I will update if I run into the issue again), but I'd still be interested in a more detailed answer. By performing the following steps, I was able to progress to the next turn:

  • Select a different city
  • Add an aditional building/unit to the build que for the second city
  • Return to the problem city
    • The problem city shows the build list for the previous city
  • Selct a building/unit that the Problem city is capable of building (some items listed have already been build/can't be built)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.