1

I'm trying to host a multiplayer game in Heroes: Might & Magic 7 to play it with friends, but they can't join my games and vice versa.

Of course I tried opening the port 20715 (both UDP and TCP) on my Router and my Windows-Firewall but they keep getting the Error Message: "Connection timed out" while trying to join my games.

Is there any hidden port I also need to Open or what could be the reason of it not working?

Also are there maybe any other possibilities of starting a game with my friends online?

  • are you guys connecting via IP address or through matchmaking? – user106385 Nov 7 '15 at 23:35
  • Some antivirus have firewalls, like Karspensky. You would need to open the port in that firewall too – vianna77 Nov 8 '15 at 22:07
  • @Timelord64 we are connecting through the Game Lobby (1 is Hosting the Game, the other one trying to join) – Werdli Nov 9 '15 at 9:48
  • Have you port forwarded the following ports?: TCP/UDP: 27015 Uplay Launcher TCP: 80, 443, 13000, 14000, 14008 – Sean Nov 12 '15 at 9:35
1

Per RavenM's suggestion, I'm turning this into an answer: I would suggest that you try using a VPN/VLAN software like LogMeIn Hamachi in order to accomplish the multi-play while circumventing the port forwarding business that usually accompanies these problems. I've used this software, personally, several times, in order to play Terraria and Warcraft III. Here is a YouTube tutorial on how to download and install Hamachi as well as creating and connecting to a network (YouTube: Hamachi Tutorial).

Keep in mind that any person that you want to be able to play with you will have to download Hamachi and connect using the same connection method in the video (not necessary to create their own network though).

The video has a download link but I will provide one here to get you started or to at least allow you the ability to research it: Download page for LogMeIn Hamachi.

|improve this answer|||||
0

Don't know its an practicable option for you (as it is insecure ^^)

But I had exactly the same problam and even after configuring all as it was expected to be, it didn't work, but it worked after just fully deactivating the firewall.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.