To make things clear, I know how to and can dock, CoM thruster placing, translation, RCS build aid, 'cotrol from here' etc inclusive. I've built a multi-piece orbital station that was assembled in orbit with a medium amount of anger.

Now I'm bringing some tourists to visit the station for a contract in a smallest ship imaginable (CommandPod, Bit of fuel, PoodleEngline, RCS thrusters @ CoM). Successfully dock this with a station, but because of a hilarious bug in KSP right after docking a piece of the station "exploded due to overheating". So I save-load and can't dock this thing for a few hours straight.

I usually use MechJeb Smart A.S.S. Target+ orientation aid on both ships for help when docking to a big station, but I was not able to re-dock again after the damn bugged explosion with or without using this setting.
I suspect this could be caused by constant woobling/rotation of the station.

I read here that there's a "TGT/PAR-" orientation setting for Smart A.S.S., - how can I enable that one?

But my core question is how do I cheat docking if not joining the ships 'full auto', but at least making the manual dock part as easy as possible.

  • When it's due to overheating, it might be a problem with the (still very glitchy) heat exchange system and not with wobbling. Cheating your parts together might not solve that issue. But you might be able to fix the issue by modifying the current heat values of the parts in your savegame.
    – Philipp
    Nov 4, 2015 at 13:20
  • @Philipp You can cheat heat away (and monitor it) in debug toolbar: ALT+F12\Physics\Thermal -> max radiation,.
    – PTwr
    Nov 4, 2015 at 18:59

2 Answers 2


For station:

  1. ALT-F12 \ Physics \ Thermal -> slide Radiation factor to maximum. Should help with heat issue.
  2. Use time warp to remove wobbling.
  3. Position station docking port closest to station CoM axis toward normal or anti-normal (magenta triangles). That way even if it time passes it will still point north/south instead of running away from your capsule.
  4. Time-warp again to remove residual wobbling.

For capsule with MechJeb:

  1. ALT-F12 \ Physics \ Thermal -> slide Radiation factor to maximum. Should help with heat issue.
  2. Get to different orbit, lower orbit will save Delta-V. Higher is preferable when target is below 80km due to atmosphere. (You probably can skip this step)
  3. Match planes with target. (Half of issues with docking comes from difference in inclination)
  4. Hohmann transfer to target. Yup, it works great for orbit rendezvous with crafts as well.
  5. Fine tune closest approach to target.
  6. Match velocities with target (at closest approach to target). Now you should be pretty much in same orbit, stable enough for spacewalk for long time.

With target docking port in stable position and orbits matched by MechJeb docking should be easier/safer than automatic. (MechJeb hates my solar panels >.<)

And remember, there is always The Claw.

  • can I use the Claw for force-docking somehow? Nov 5, 2015 at 11:15
  • @SergiiZaskaleta it can dock with any almost any part (heck, it can dock with Kerbal head), so you won't need to aim at docking port. Just touch any fuel tank with (armed) claw at low relative velocity (below 5m/s) and done. It is less solid connection than normal docking port but it is great for temporary connection. You will surely get some wobbling from collision but you can use time warp to flesh it out.
    – PTwr
    Nov 5, 2015 at 11:23
  • Radiation factor to maximum did not help with any exploded due to overheating issues =( Nov 5, 2015 at 19:04
  • @SergiiZaskaleta Luckily it should be fixed in next update. Energy neither created nor destroyed when exposed area changes.
    – PTwr
    Nov 6, 2015 at 8:26

Smart A.S.S. TGT/PAR- setting is (as of MechJeb 2.5.3) is ADV -> Reference: TARGET_ORIENTATION, Direction: BACK. Applying this orientation leaves you only with managing translation to align one docking port above the other and makes docking substantially easier.

My inability to dock itself was caused by a bug#1158 in KSP where a docking port became incorrectly marked as 'docked' after a quick-save. In this case port magnetism does not kick in and ports just stare at each other... Editing the save file and marking the corresponding port state = Ready re-enabled the docking port.

Steps above helped fix the issue and let me dock, though this doesn't help to cheat docking per se.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .