2

I have SourceMod set up for a listen server on my copy of TF2. This worked fine as of the Invasion update. However, I updated to the latest version of TF2 and now when I start a server, it crashes before the map loads. This happens regardless of whether I'm setting up a LAN game or a bot match. Removing SourceMod seems to fix it, so I think the problem is with SourceMod itself.

SourceMod and Metamod both load, I can use meta version, and I am using the -insecure flag, but I am unable to start any servers while using them.

I am able to access TF2 with SourceMod enabled, and I can connect to other servers, but I can not start my own without the game crashing.

Does anybody know why this is happening and how I can fix it?

  • I'm surprised. I didn't think MetaMod: Source or SourceMod worked on Listen servers for much longer than that. – Powerlord Nov 8 '15 at 18:06
  • @Powerlord It does if you add -insecure, but I added that, and it isn't working. – ASCIIThenANSI Nov 8 '15 at 19:43
1

The version of SourceMod or its plugins is out of date.

Usually just updating SourceMod works, however, if the game keeps crashing, check your plugins for new updates.

In my case, the gamedata for TF2Attributes had to be updated. I updated both SourceMod and TF2Attributes and it works fine, I can create servers and people can join them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.