5

My main gaming machine is a Windows 8 box attached to my TV. When my husband wants to watch TV, I like to play games from my laptop. Since switching OS from Ubuntu to Fedora on my laptop, Steam has stopped detecting the gaming machine as an in-home streaming server.

What is preventing this, and how can I remedy it so that I can once again stream games to my laptop?

6

I've found the solution -- Fedora's firewall is blocking Steam by default. (Good firewall! Sit. Stay. Steam is a friend. Say hello).

Fire up /usr/bin/firewall-config (or just enter "firewall" in your DE's application menu serach box) to add an exception. Once it's open:

  1. From the drop-down at the top, select the Permanent configuration.
  2. From the tabs below that, select the Services tab.
  3. From the Service pane at the left, click the Add Service button
  4. In the dialog that appears, name the service steam-stream. Any version number should suffice (I used 0.1). Ensure the new service is selected when the dialog is closed.
  5. Ensure the Ports and Protocols tab is selected, then click Add at the bottom of the pane.
  6. Enter 27036 as the port number and tcp as the protocol, then click OK
  7. Repeat steps 5 and 6 to add exceptions for:
    • udp port 27036
    • tcp port 27031
    • udp port 27031
  8. From the tabs below the Configuration dropdown, select Zones
  9. From the pane on the left, ensure the public zone is selected
  10. From the pane on the right, ensure the Services tab is selected
  11. In the list of services, scroll until you find the steam-stream service, and check the associated checkbox
  12. (Not sure if this is necessary) From the menu bar, select Options > Reload Firewalld
  13. Restart Steam

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.