4

The various followers in Skyrim will frequent say things like "we've stopped, what is it?", "what did you need", etc. They speak these lines repetitively and will sometimes repeat the line within seconds. Since I started using multiple followers, it has gotten to be very nerve-grating.

Is there any way to disable the idle chatter?

2

Follower Commentary Overhaul has got you covered. From the mod's FAQ:

Q) I keep an unsafe amount of followers in my house and it's a cacophony of madness!! How do I stop it

A) Don't fret, I've got you covered! FCO includes an MCM where you can adjust the frequency at which comments are made as well as which voicetypes are able to make them! 100% is the default frequency, and is balanced best for vanilla play or small groups of followers, but if you roll with a large following in combat or at home, you can slide it on all the way down to 10% frequency. If you only want particular voicetypes chiming in, or just can't stand one in particular, you can switch them on and off at will as well.

You can just set frequency of all comments to 0, which will effectively disable them.

  • 1
    It should be noted that setting frequency to some other value will have side effects. The purpose of the mod is to make followers borrow lines from various NPCs (e.g. Derkeethus talks about stealth a lot) in order to increase the variety of comments. YMMV on immersion here; I found it rather weird. – Kevin Nov 18 '15 at 22:26
  • Yeah, I wound up just using the frequency feature, and disabling the extra lines for all voice types. It was causing one of my followers to become very unlikable because her random dialog gave her an adversarial and avaricious personality. – Zauber Paracelsus Nov 21 '15 at 23:47
1

Follower Commentary Overhaul turned out to not work so well. I could turn down the frequency, but some of the lines made followers more annoying. And turning off the extra lines seemingly made the frequency have no effect.

However, I discovered that the Amazing Follower Tweaks mod (which I already had installed) has an option to simply disable the chatter for individual followers. The option that I need to turn off to disable idle dialog is Tweak Options -> Settings -> NPC allow idle chatter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.