2

I tried everything that I found in the internet to solve this problem and still I can't solve this problem.

Basically, what is happening is that whenever I log-in to iCCup and do the /netinfo command, my Client UDP which shows what port the game is using is shows up as some random number such as 19169 or 65532 and changes everytime I restart the game. Which is problematic since the port required to host games in Battle.net is 6112 and the game is not using that. I already forced in the registry for the game to use the port 6112 until 6119 and still the game doesn't use those aforementioned ports.

Any help is appreciated, thanks. :)

  • 1
    What is the exact output of the /netinfo command? There are two types of ports involved, one for incoming connections when hosting(should be using #6112) and one or more for outgoing connections (such as the connection to the battle.net servers, or to other hosts). The second one can use any port number. – antipattern Nov 20 '15 at 13:41
  • I just ran the /netinfo command right now and the output is: Server TCP: xx.xxx.xxx.xx:6112 Client TCP: xxx.xxx.xx.xx:19234 Client UDP: xxx.xxx.xx.xx:19235 and Game UDP: none – Freckles Nov 20 '15 at 14:06
  • That looks right. Was that command run when you were hosting a game, or what was the situation? If you were currently hosting, then you are the server, which actually uses the port 6112. Client ports do not matter. Telephone analogy: If you use your telephone, you need to know your targets number. The recipient will just reply to any number. This is similar to a client opening the connection to a server. The server does not care about which port a client is using. If something is not working, like people being unable to join, I would examine Firewall and Router settings. – antipattern Nov 25 '15 at 12:48
  • I'm actually connecting to a 3rd party PVPGN server (iCCUP) and the IP that the Sever TCP shows is not my IP. Btw, I ran the command both inside and outside the game and I still can't host a game. – Freckles Dec 2 '15 at 8:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.