0

I have a laptop with a discrete Nvidia GeForce GT 640M LE graphics card (together with an integrated Intel HD Graphics 4000). My display has native resolution of 1920x1080. Unfortunately, when I try to play games with smaller resolution (e.g. 1280x768, etc. — older games, or very demanding new games), they show in a small "window" in the middle of the screen, with huge black frame around, wasting most of my display area :( I've seen on other computers (including really old ones) that usually such games "scale" to fill the full screen (making the pixels "bigger" and more visible). I've tried to find out how to change this, but with no success. Is it possible to fix/change this, and if yes then how?

3

Yes, it is possible, though it's horrendously unintuitive and weird to configure. I've tried to find it out many times, but wasn't able, so I stayed with this small window for years. But I've finally manged to find the solution! The following guide is based on two forum threads (big thanks to those guys!). I believe it is valid for both 640M (including LE) and 540M.

  1. First of all, you actually have to change the options of the integrated (Intel) graphics card, NOT the Nvidia one!!! To do this, get to your Desktop, right-click it, and choose "Graphics Properties" option.
  2. It will open the "Intel Graphics and Media Control Panel". You can choose either Basic or Advanced mode. You should see a window looking somewhat like below (only in your language):

  3. Yay, there is the "Scaling" option, finally! but if you try to click it, you'll find out that you can't change it... ouch :( :( :( Fortunately, there's a solution. The next important step is that you must click Resolution and choose some SMALLER resolution! (argh, rly? I tell you, that's not what they call "intuitive UI")

  4. This finally gives access to the Scaling option! The choice I'd advise here is to keep proportions/aspect ratio (not sure how is it named in English version):

  5. Now, before closing the window, be careful to change the Resolution option back to your native resolution (for me, 1920x1080). Otherwise, when saving, it would switch your default Windows resolution to the smaller one... X-| The "Scaling" option will then show a different value, but don't worry: you can check again, that choosing any non-native resolution above will show the "Proportional" value again. So, finally, click Apply/OK, then OK again in the small window (remember to switch back to the biggest resolution before doing Apply/OK). And that's all, you should be done!

Hope this helps. It worked for me, and I can finally see what's there in games which are either very old, or too new and demanding...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.