My current desktop reso is 1366x768

In cs 1.6 I have selected display option as Normal and Resolution as 1024x768.

In this settings I don't get those vertical black side bars which make the playing screen square.

Atm it is rectangular but I wanted square.

How do I get the vertical black bars while playing cs 1.6?


2 Answers 2


There are two ways to fix this.

First fix:

Nvidia: Go into the Nvidia Control Panel, open the "Adjust desktop size and position" menu, select "Aspect ratio" scaling and set "Perform scaling on:" to "GPU".

Picture from Nvidia Control Panel

AMD: Open the My Digital Flat-Panels part from the left of the Catalyst Control Panel, then, enable gpu scaling and pick maintain aspect ratio.

Picture from Catalyst Control Panel
Image courtesy amd.com.

Intel: Open Intel HD Graphics Panel, open the display menu, switch to 1024x768 and make sure the "Maintain display scaling" button is ticked (not scale full screen), open game while in this mode. Picture from Intel Control Panel

or if you have the legacy Intel Graphics Media Accelerator, you should open it, select display settings and click on the Aspect Ratio Options button. In there, select "Maintain Aspect Ratio" and save.

Picture from Intel Graphics Media Accelerator
Image courtesy intel.com.

Picture from Intel Graphics Media Accelerator
Image courtesy techtoggle.com.

Second fix: Play in windowed mode.

  • How do I open Intel HD graphic panel? I have something called as Intel Graphics Media Accelerator installed in my pc.
    – user131233
    Nov 28, 2015 at 19:42
  • @user131233 editing the answer for info about that.
    – ave
    Nov 28, 2015 at 19:45
  • @user131233 see the edit.
    – ave
    Nov 28, 2015 at 19:48
  • I did this, got the vertical bars but now the gun is held on the left side..earlier it was on the right side of the pointer. Any clue how to change that?
    – user131233
    Nov 28, 2015 at 19:51
  • @user131233 please run cl_righthand 1. It wasn't caused by this though, it is a bug in CS 1.6. Please hit the green tick on the answer if the answer helped you.
    – ave
    Nov 28, 2015 at 19:54

Click library( On top) select counter strike(from the list which is on the left side),right click on counter strike, select properties then select launch option. And copy paste this into your launch options-

-nofbo -stretchacpect

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .