4

I've checked in my library and it said that i had the Old Hunters DLC installed. I purchased it. I defeated Vicar Amelia. I tried restoring licenses. I tried contacting support but it always says they're down for some reason. Any ideas?

  • 1
    Did you touch the skull sitting on the alter in the room where you fought Vicar Amelia? I believe this is the actual trigger that allows the Eye of a Blood Drunk Hunter to appear in the Hunter's Dream, not the actual fight with Vicar Amelia. – TwentyMiles Dec 7 '15 at 20:13
3

I got the exact same problem. Look on the disk box for the region code. Mine states "Region ALL" (instead of Region 2) but I got the DLC for Region 2. Thus, it will not play.

☹ Welcome to the horrid world of DRM…

Note that as a gesture of good will, Sony refunded me. However, I would not expect this to be a common occurrence thus do check regions before buying!

| improve this answer | |
2

I'm not sure at what point in the story you get to access the content, but I'm pretty sure the actual data was downloaded and installed in the 9gb patch a few days ago. Once you "have" the DLC (purchased it on PSN), you'll just have to get to the appropriate place in the story and fulfill whatever criteria is necessary.

Also see this question for more information. (Duplicate?)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.