I ordered American McGee's Alice from eBay and it seemed to read just fine when I put it in my computer. The autoplay menu worked correctly and allowed me to install the game, but when I double-click the icon to start it (or when I click "play Alice" from the autoplay menu), a loading spinner pops up next to my mouse and then nothing happens. The program seems to silently crash immediately after opening. No error messages come up and I don't even see the splash screen.

My graphics card drivers are up to date and it doesn't seem to work under any compatibility settings either (I am running Windows 7). No one else seems to have this issue - am I going crazy? What could be the problem?

  • 1
    I don't know about the question title. I think the one Robotnik proposed in his Meta answer would be more likely to lead someone to actually finding this information
    – DCShannon
    Dec 7, 2015 at 23:12
  • @DCShannon I don't think so because the games may error in different ways, or in this game's case, show no error at all. I also wasn't aware of the Windows update that caused the issue. The only thing that these games have in common is that they are all CD-based. Dec 7, 2015 at 23:54
  • 1
    Well, that sucks. Still, it's not a very helpful title.
    – DCShannon
    Dec 8, 2015 at 0:07

1 Answer 1


There was recently a security update by Microsoft implemented for Windows 7 and 8 that breaks native compatibility with a very large handful of old CD-based games, namely anything with SafeDisc or SecuROM write protection built in. This security modification is built in to Windows 10 and cannot be worked around. The following is a highly abbreviated list of potentially affected games:

  • Age of Empires 2
  • American McGee's Alice
  • Battlefield 1942
  • Civilization III and IV
  • Command & Conquer series
  • Crysis
  • Diablo II
  • Empire Earth series
  • Far Cry (1 & 2)
  • Grand Theft Auto series
  • Halo
  • LEGO games
  • Might & Magic series
  • Need for Speed series
  • Rainbow Six series
  • Star Wars games (including KOTOR)
  • The Sims (1 & 2)
  • Total War series

The solution for this problem is actually pretty simple (Windows 7 and 8 only). Simply re-enable the driver service disabled by the security update and start the service. To do this, open a command prompt as an administrator:

Windows button -> cmd.exe -> right-click -> Run as administrator

Run this command (with the exact spaces) to reenable the driver's service:

sc config secdrv start= demand

You should get a [SC] ChangeServiceConfig SUCCESS message. Then run this command to start the service:

sc start secdrv

Then open the game and it should work! To be "safe," you can stop the service by restarting your computer or using the command:

sc stop secdrv

If you don't want to have to start this service every time you turn on your computer, you can set the configuration to auto instead of demand. According to the security update, this may potentially leave your computer at risk for some virus attacks though, so use caution while this service is enabled.

  • I have like half of those games :/ bummer
    – ave
    Dec 7, 2015 at 10:52
  • The fix is trivial, but since most CDs simply do not use the above methods anymore, and the "drivers" cause significant drive performance issues, it would make sense to disable the security support.
    – Nelson
    Dec 8, 2015 at 6:19
  • Would No-CD cracks be sufficient to get around the problem?
    – bwarner
    Dec 15, 2015 at 23:20
  • @bwarner you can but it will remove moltiplay. May 4, 2017 at 19:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .