0

When I downloaded minecraft_server1.8.8.jar I couldn't open it by double clicking on it, nothing would happen.

I tried opening the eula.txt file and changed eula=false to eula=true so I'm still confused as to why it doesn't work.

What do I need to do to open the minecraft_server.jar file?

  • You can't open/run jar files like that (unless its part of your path variable). To open it, you need a program like 7zip or winrar. You can looked at the pacakged contents (although they are just compiled code so its all nonsense). To actually use it, there is a special command, @Aequitas has that in his answer. In general, to run jar files though you can simply go to your cmd and type cd locationOfFile, then java -jar filename.jar – Ashwin Gupta Dec 8 '15 at 3:59
  • 1
    "How to open a jar file" is not specific to Minecraft in any way, making this question off-topic. – pppery Aug 16 '19 at 1:33
  • 1
    I'm voting to close this question as off-topic because the problem is not specific to gaming. – Joachim Aug 16 '19 at 8:42
3

jar files need to be open with Java;


Windows

Go to the folder that the .jar file is located. Then push alt+D type in cmd and hit Enter. This will open cmd.exe with the location set to the correct spot, otherwise you could change directory with the cd (directory) command.

Now just type in java -jar minecraft_server1.8.8.jar and hit Enter to open the file.


Linux

Open the Terminal: Applcations > Accessories > Terminal. and then change directories to where the Minecraft server jar is located with the cd command. Then type in java -jar minecraft_server.jar


Additional arguments:

  • You can add no gui to the end of the command to open the server without the GUI
  • You can specify the initial and maximum memory allocation pool for the Java Virtual Machine by adding -Xms500M and -Xmx1G between java and -jar. You can change the size (the 500M and 1G parts) to whatever you like. The default value for xmx is 256MB, if you encounter a java.lang.OutOfMemoryError you may need to increase xmx when you start it with this command line.
|improve this answer|||||
  • @Minecraft sorry I had a typo, it should be an _ not a . I've edited my answer – Aequitas Dec 8 '15 at 3:45
  • mine opens as a text file any help? I tried everything – BRAEGON Aug 28 '18 at 10:52
  • 1
    You know, "no gui" is not correct. nogui it has to be. – Mephiztopheles Nov 27 '18 at 18:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.