I acquired several pieces of power armor on my travels with the intent of adding them to my suits sitting around Sanctuary Hills which were all missing certain parts.

The problem is that some of the armor pieces were completely broken, condition was 0 and interestingly weight was also 0.

When I tried to add the armor piece to a suit I get a notification telling me I can't add armor to a frame if it is broken, so how am I suppose to repair them if they are not part of a suit that can be walked over to a power armor repair station as outlined in this question?

I tried repairing them from my inventory directly at the repair station, adding them to the workshop inventory and repairing them from the armor workbench but none of these worked.

Is it even possible to repair a completely damaged power armor piece and if so how do I do it?

4 Answers 4


Yes it is possible. The broken armor pieces have to be in your inventory, then you need to go to a power armor station (while not wearing the power armor) and go to craft mode (by pressing A on Xbox One, X on PS4, and E on PC)

Then you can see all the pieces you have in your inventory and you should be able to repair them by pressing Y / Triangle / T, no matter if they're completely or partially damaged.

  • 3
    I did already try interacting with the power armor repair station like this, but the X - craft button (I am playing on PS4) was grey out and didn't respond. Turned out that once I had any suit of armor in the repair station I could repair the other pieces in my inventory. In my case I did need to have a set of armor in the station although this may be a bug. Can you confirm if it normally works without have a suit in the station?
    – Colin
    Commented Dec 16, 2015 at 12:34
  • 17
    You must have a frame in the station to repair components, wether you're going to put them on the frame or not.
    – T.J.L.
    Commented Dec 16, 2015 at 15:03
  • 1
    @T.J.L.This is really the crucial bit of information and deserves the rep.
    – Colin
    Commented Dec 21, 2015 at 22:50
  • Try this!! Helped me to see it in the video instead m.youtube.com/… Commented Jul 8, 2017 at 21:27
  • you need to check you have the perks at the right level as well Commented Sep 24, 2017 at 14:19

Additionally to @WayneEra's answer:

When you let a companion wear Power Armor, it is possible that they'll automatically unequip broken pieces. When you see that, you'll need to trade with your companion to get the piece from their inventory into yours, so you can repair it.

Once the piece is repaired, you can give it back to your companion and they'll automatically add the repaired piece to their Power Armor frame, assuming they're still wearing it.

  • You have to tell them to equip it once you give it back.
    – DCShannon
    Commented Dec 17, 2015 at 7:26

Power armor components usually require 2 pieces of steel each. These can be in your inventory or in your workshop inventory. Steel can be found in junk items, ball peen hammers, wrenches, etc, or by scrapping signs, guard rails, lamp posts, etc from the workshop interface. If you don't have enough steel the power armor rack won't repair them.


When you don't have the required items to fix your armor part, the equip funtion will still be greyed out. Try and hit equip to see what you're missing.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .