So I'm having a hard time trying to run a game named The Sting (2001) on my Windows 7 64 bit laptop. I've tried running it on compatibility mode, but the game just ends up closing right after I hit "play".

I've read that it could be because some of the DLLs required to run the game aren't available anymore on the new Windows versions. I have no idea where to find them, nor do I know how to proceed with that information.

Any help is highly appreciated.

  • do you know the exact DLL's you need? – Sad32x Dec 17 '15 at 13:50
  • No, sir. I'm not even sure that's the real issue. It was just a possibility I've seen someone commenting. – Daniel Monteiro Dec 17 '15 at 14:36
  • have you tried to check the event viewer? that may bring the exact error which happens when you open the application. – Sad32x Dec 17 '15 at 15:11
  • Actually it doesn't show any error. The game just closes. There's no window popping up with any message. – Daniel Monteiro Dec 17 '15 at 15:26
  • 1
    You may want to check this question in case it's the same issue – JonK Dec 17 '15 at 19:04

Your issue is probably stemming from the fact that windows works differently now than it did around the windows 2000/xp era. As such, resources that your game is looking for either don't exist in your current version of windows or are accessed in a completely different manor. My recommendation would be to install a free virtual machine program VM Virtualbox from oracle is a good one.

Hope this helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.