2

I am trying to get Team Arena to run as a dedicated server on OSX using the ioquake3 engine. I've managed to get Q3 to run okay but not the addon. Everything is installed for Team Arena in the missionpack folder. I tried running the game_restart missionpack command but the console says the command can not be found. I also tried adding this to the autoexec.cfg but didn't have any success.

I am running version Q3 1.36.

The OS X is pretty only as it's a spare Xserve running 10.5.8

Can anyone offer some help?

0

Okay, have the solution. I have a shell script with the following:

exec /Applications/ioquake3/ioquake3-1.36.app/Contents/MacOS/ioq3ded.ub +set fs_game missionpack
0

Instead of attempting to use game_restart, try launching the game with the +set fs_game command line parameter (for example ./q3ded +set dedicated 2 +set fs_game missionpack) specifying the sub folder of the game content you want to use (in this instance missionpack).

  • I just have 'ioquake2-1.36.app' on OSX so can't find q3ded in the filesystem and not sure if I can pass parameters to a .app – Ric Dec 18 '15 at 12:17
  • so do ./ioquakewhatever +set fs_game teamarena – kalina Dec 18 '15 at 12:20
  • sorry I misread the foldername you had it installed it, obviously swap out teamarena with missionpack – kalina Dec 18 '15 at 19:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.