1

This is the status quo:

I have finished making the very structure of the Command Module I'm making, and I'm trying to add in a command that gives me a book that has contents in it.

I succeeded in 10% of the command, which is coloring the first part of the book, only problem is, the next part of text after it is supposed to be colored black, which it isn't.see the red part after 'The Lab'?

I've tried this post from the Minecraft Forums, however I found it unhelpful, as I've tried on what it says about inheritance.

P.S. My Minecraft version is 1.8.9.

  • 1
    There is currently a bug that causes a difference in how inheritance works within books compared to other features using the text component (see MC-62866). – Skylinerw Dec 22 '15 at 0:22
3

Identifying The Problem

I think the problem is that you need to update the "-----" at the end to black. The part I have highlighted below shows that those are going together. (The "The Lab" and the ending "-----" both have the same red and bold.)

Picture 1

Solving The Problem

To solve this, you will want to insert this... (Between where the " and ] are; near the red.) Picture 2

Example:

/give @p written_book 1 0 {resolved:0,generation:0,author:"Ry3ks3u",title:"The Lab",pages:["[\"------------------\",\"\n-----\",{\"text\":\"The Lab\",\"color\":\"dark_red\",\"bold\":true},{\"text\":\"-----\",\"color\":\"black\"}]"]}
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.