-5

I've recently run into a very annoying problem in Assassin's Creed Black Flag. I am playing this game on my laptop which have the following specs:

Intel Core i7 4510U @ 3.1 GHz (At turbo boost)
8 GB RAM
NVidia 840M 2GB
Intel HD 4400 2GB
Windows 8.1 64bit

When I start this game, I either get 45+ FPS or for some reason I get around 25 FPS on the SAME SETTINGS. Clearly, over-heating is not the problem here because when I am able to run this at 45+ FPS the FPS doesn't drop less than 40 even after 4 hours of gameplay.

Things I've noticed when I get 45+ FPS: GPU maintains a temperature around 65, and the GPU fan runs at full speed.

Things I've noticed when I get 25 FPS: GPU maintains a temperature around 44, and the GPU fan does not run at all.

Things I've done:

  1. Updated my NVidia drivers
  2. Went to NVidia Control Panel and set default GPU to NVidia
  3. Went to Nvidia Control Panel and preferred Max power for this game

Can any of you guys please point out where the problem might be?

  • I think this question has some serious issues. There are any number of problems specific to your setup that could be causing this issue. Are your drivers updated? Is the game fully patched? Do you have background processes running? Is your laptop going into powersave mode? I don't think this question is a great fit for Arqade, but good luck with your issue. – two bugs Dec 23 '15 at 15:05
1

Background process might be factoring in. Check what else is running and close any unnecessary programs.

If you have any programs like evernote or dropbox, check if their syncing schedule is during the times you experience drops?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.