2

I'm still having issues installing the game off the disc. I have more than enough space and the disc isn't scratched but it keeps getting stuck at 63%. Any advice on how to get this to work? Really want to play the game.

4
  • How much memory do you have, and how much is it asking for? Dec 29 '15 at 19:13
  • Well on the back of the game case it says I need 10.5GB and I went to my system information and I have 32GB left
    – Brody
    Dec 29 '15 at 19:27
  • When you say "keeps getting stuck", how long do you actually leave it, before determining that the game has frozen in installation?
    – user106385
    Dec 29 '15 at 23:02
  • Well like the screen keeps changing backgrounds so I don't think it's frozen but it gets to 63% and the longest I've let it sit was 2 hours
    – Brody
    Dec 29 '15 at 23:11
2

If you have registered your game with Uplay, you can download the game and all updates through your Uplay desktop console. It takes a while, but if you cannot install with the disks, like me, download that way.

1

Here is a post I found on GameFAQ of someone who had the exact same issue.

They were able to get it to work with the following steps:

  1. Go to Settings > Network> Uncheck the 'Connect to Internet' box.
  2. Install disk completely.
    (note that in can still take a while, still several hours rather than possibly over a day long...)
  3. Turn your network settings back on.
  4. Delete the patch if it starts to auto-download when the disk is inserted.
    (via the Notifications > Downloads menu)
  5. Re-prompt updates by using the "Check for Updates" option on the Far Cry 4 game icon.

From what I've read online, it looks like it just tends to take an atrociously long amount of time. Hopefully those steps help a bit, but you might still have to muscle through quite a long install. (IF you decide to restart for any reason(s), it might be a good thing to make sure you don't have any residual FC4 files on your system before restarting)

2
  • I've tried what you suggested but it got stuck at 63% again
    – Brody
    Dec 29 '15 at 23:12
  • Tried what you suggested and still got to 63% then sat at 63% for two hours and then my ps3 reset
    – Brody
    Dec 30 '15 at 3:32
0

I had the same problem. I was able to solve it by lowering the air temperature in the room by about 10°C and placing the console on a cold marble plate to cool it.

You should also try placing the PlayStation 3 on the other side; for example, I always place it vertically, so I placed it down horizontally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.