I am having a bad time with my PS3 which I've had for about 2 years, PS3 slim with 120GB HDD. I've ran across a problem with my WiFi connecting to it. My PS3 doesn't accept my WPA2 key, I've changed it to a new key then my PS3 successfully connected to it. After 5 minutes it then drops connection and says my WPA key is wrong which it isn't.

So I changed my key again, it connected to the WiFi successfully, then an hour later it dropped connection to it then told me my WPA key is wrong when it isn't! My other devices connect to it just fine, like my Mac, iPhone, etc. But my PS3 doesn't connect to it properly. I get signal strength of 80-90%+

Is there any reason why it keeps doing this?

I am upstairs and the router is downstairs, I cannot use a Ethernet cable because it's far too long to connect to it.

  • This could probably be on SuperUser. I would suggest that perhaps you are not using DHCP and another device is kicking the PS3 off because it wants the IP address? Oh and, ethernet, you mean ethernet, not adsl ;p
    – Neon1024
    Commented Jun 21, 2011 at 15:19
  • 1
    @DavidYell, this is generally considered on topic as discussed on meta here, and in this discussion, it's mentioned that SuperUser really doesn't want us to suggest gaming-related questions for migration. The real question is whether or not anyone here can troubleshoot this as effectively as an ISP support person could. Commented Jun 21, 2011 at 17:18
  • Have you tried using an alternative wifi channel? One which isn't crowded?
    – Neon1024
    Commented Jun 22, 2011 at 8:40

6 Answers 6


A few thoughts:

1) ensure your router's DHCP server is configured to allow enough clients to support all your hardware. If you have 10 clients enabled for DHCP and 11 connections are attempted, it is plausible that one device is grabbing an address and then the ps3 is left waiting for an expired lease. This can happen more often with shorter lease times (check the lease time and compare to the timing of ps3's loss of address). I like to assign static addresses (via the router interface, not on each device) to known devices on my network.

2) if the ps3 is spamming for a new lease, the router may be ignoring it by implementing a timeout. The solution might be to disable wifi and wait a few minutes.

3) You might have a mixed-network issue. If all of your devices are wireless-G, try setting your router wifi to G only.


I had this same problem. I finally found out that the problem was that I had the same SSID and WPA key for both 2.4GHZ and 5GHZ on my router. I changed the SSID and WPA key on the 2.4GHZ and connected to that on my PS3 and it worked.

I guess PS3 doesn't work with 5GHZ?

  • Correct, it does not work with 5GHz as it only supports up to the g protocol and 5GHz requires at least n. Commented Jan 19, 2017 at 16:53

Not sure if it will work for you, but I had the same issue, after trying everything with the router with the exception of running an ethernet cable, I entered my settings and disabled the UPnP and it worked. Hope this helps.



Switch to a WEP if you aren't worried about the security as much and put your router on "don't show SSID" in you router setting or

WEP isn't as secure as WPA but this has fixed the problem for people I know on their ps3s.


I have seen very similar issues when the signal suffers interference. Even if you have high signal strength this can happen.

Simple things you can try:

  • Configure your router to use a different frequency range
  • Run an Ethernet cable - unless you have an exceedingly large house this will be a simple workable solution
  • The OP's already mentioned that it's not possible to use an ethernet cable. Commented Jun 21, 2011 at 21:02
  • 1
    @Dave - not really, which is why I had that as option 2. He just said it was too far, which is unlikely. Option 1 is the best bet for a simple fix though, sorted one of my installs which had the same symptoms.
    – Rory Alsop
    Commented Jun 21, 2011 at 21:15
  • In defense of ROry: it may be too far, but perhaps the OP could move some equipment temporarily in order to test.
    – horatio
    Commented Jun 21, 2011 at 21:18
  • inSSIDer (www.metageek.net/products/inssider/) is good for checking for interference from other wireless networks (it's free too).
    – jwaddell
    Commented Jun 21, 2011 at 22:49

Don't use WPA key found on router. Use the password you set up to connect to Wi-Fi.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .