0

this is the error it gives me

My Minecraft server doesn't open anymore. The first 2 times it worked, but when I try to run it with a edited server properties file it won't open.

I already tried the .exe but that doesn't work either.

How can I make it run?

2 Answers 2

1

This is the reason why your server isn't running:

[22:51:00] [Server thread/WARN]: **** FAILED TO BIND TO PORT!
[22:51:00] [Server thread/WARN]: The exception was: java.net.BindException: Cannot assign requested address: bind
[22:51:00] [Server thread/WARN]: Perhapes a server is already running on that port?

With that said, ensure you are not running another copy of the server on your computer, or a server (for anything) that uses the port 1000.

Here are some possible solutions:
Most likely, it's #1.

  • Try closing any other Minecraft servers that you may be running on Port 1000.
    Perhaps try killing all Java instances by running (Win + R): taskkill /f /im javaw.exe and then restart your server.
  • You may be accessing your computer using Cybergate RAT (Remote Access Terminal).
    Try using Remote Desktop Connection mstsc instead, as you are using Windows 7/Vista.
  • Check for any other programs using Port 1000 and close them.
1

As aytimothy said, the port your minecraft server tries to run on is already used by another process (which may be another instance of the server or a different program). If you changed your minecraft port by accident, open your server.properties file, change server-port=1000 to server-port=25565 (which is the standard minecraft port) and restart your server.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .