3

I've freed a master swordsmith from his cage in a "Person in distress" area, near Mulbrydale, but he doesn't move and I cannot talk to him (I'm not even prompted with the "E Talk" tooltip).

Stuck master swordsmith in Velen, near Mulbrydale

I've tried everything I could think of: look for a quest that would be necessary to talk to him, close/open the door, look around for a last pirate that should be killed, meditate, reload, restart the game, etc.
Also when I leave and come back to the Velen area, this red glowing unsent letter (that I already had in inventory btw) appears on the floor,but it doesn't unlock anything.

Red glowing unsent letter, near Mulbrydale

Did I miss something, or is it a bug and I'll never be able to talk to him ?

Note: I'm currently playing on version 1.11, on GOG Galaxy.

  • Usually those people, after being rescued, will show up in a town nearby. You don't get the reward from them right away after rescuing. – l I Jan 6 '16 at 12:57
  • Yeah but they at least move out of the cell and say something; here there's nothing, the guy just stays there. Also I looked everywhere around for a last pirate that would have fled, but found no one. – Anto Jan 6 '16 at 13:00
  • have you tried leaving (fast travel out of velen) and coming back? – l I Jan 6 '16 at 13:25
  • I did, same result. – Anto Jan 6 '16 at 14:07
  • 1
    @Anto had that bug too and had to load an older savegame to get this working. The bug was caused by npc stucked in wall/ground so I was unable to find and kill him. – Nitro.de Jan 7 '16 at 9:53
5

I wrote to CD Projekt and they confirm it's a bug:

Hello,

I'm sorry about the issue that you encountered and thank you for the feedback. We are aware of it and our development team is working on the fix.

Regards, Grzegorz


It's been fixed in patch 1.12. If you cleared the area and opened the gate already, just go to Mulbrydale where the swordsmith is waiting for you.

  • 1
    Looks like it may be fixed in the 1.12 patch. – greg-449 Jan 12 '16 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.